Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Sign in using an external account
Register Forgot Password?
Search


4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.
Sponsored by Cruizin Concepts


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-20-2013, 05:02 PM   #1
I8urGM
 
Join Date: Oct 2013
Vehicle: 2003 Mustang GT
Location: Texas
Posts: 28
Default 4.6 gt 55k seems like it's loosing power

I have an 03 gt. Seems like it's running slower, a sec slower in the 1/8. No engine light, no stalling. No noticeable issues. Has anyone had this issue or have an idea what it might be?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
I8urGM is offline   Reply With Quote
Old 10-20-2013, 05:16 PM   #2
uberstang1
Chupacabra
 
uberstang1's Avatar
 
Join Date: Jul 2004
Vehicle: 1997 Mustang GT, 2002 F150 XLT 4x4 Triton
Location: wilkes-barre PA
Posts: 9,429
MustangSVT97r
Send a message via AIM to uberstang1 Send a message via Yahoo to uberstang1
Default

Run a compression check and see what you have
__________________
Street Car, 4v D1sc, 20psi,viper spec t56, Team Z/ UPR suspension.
SKELETON CREW RACING
uberstang1 is offline   Reply With Quote
Old 10-23-2013, 07:01 PM   #3
WJL
1st Gear Member
 
Join Date: Feb 2013
Vehicle: 1998 Ford Mustang
Location: PA
Posts: 132
Default

Don't forget the simple stuff, did you get fuel from a different place how long has it been since the fuel filter and or air filters have been changed, it may surprise you how much performance lost you can get with dirty/old filters maybe even check the spark plugs
WJL is offline   Reply With Quote
Old 10-24-2013, 11:01 AM   #4
I8urGM
 
Join Date: Oct 2013
Vehicle: 2003 Mustang GT
Location: Texas
Posts: 28
Default

Well two months ago i changed my spark plugs with motorcraft plugs, same day i changed the fuel filter. I also changed the air filter for a bbk filter. Ever since then the car struggles to start and doesnt run the same.
I8urGM is offline   Reply With Quote
Old 10-24-2013, 07:41 PM   #5
WJL
1st Gear Member
 
Join Date: Feb 2013
Vehicle: 1998 Ford Mustang
Location: PA
Posts: 132
Default

i would just start with the process of elimination, take the air filter off, go for a ride see if there is any difference, you can put a fuel pressure gauge in (after the filter) and measure the PSI to make sure there are no concern with a clogged filter or fuel pump issue. Pull the plugs and inspect them (could be cracked), make sure the COP are on all the way. Good luck
WJL is offline   Reply With Quote
Old 10-24-2013, 09:47 PM   #6
I8urGM
 
Join Date: Oct 2013
Vehicle: 2003 Mustang GT
Location: Texas
Posts: 28
Default

Thanks guys I'm going to try that this weekend. Hopefully it wakes it back up.
I8urGM is offline   Reply With Quote
Old 10-24-2013, 10:04 PM   #7
kzonts
5th Gear Member
 
kzonts's Avatar
 
Join Date: Dec 2010
Vehicle: 2010 V6 Premium
Location: South Carolina
Posts: 2,977
Default

Not trying to insult you, but did you install the fuel filter in the proper direction? Just trying to help.
kzonts is offline   Reply With Quote
Old 10-24-2013, 10:15 PM   #8
I8urGM
 
Join Date: Oct 2013
Vehicle: 2003 Mustang GT
Location: Texas
Posts: 28
Default

I hope so lol.
I8urGM is offline   Reply With Quote
Old 03-15-2014, 11:38 PM   #9
suprafish
 
suprafish's Avatar
 
Join Date: Mar 2014
Vehicle: 2000 ford mustang gt
Location: az
Posts: 5
suprafish
Default

Cheak your plugs. May be junk plugs. U pay for what ya get with plugs
suprafish is offline   Reply With Quote
Old 03-16-2014, 07:36 PM   #10
Soldier GT
6th Gear Member
 
Soldier GT's Avatar
 
Join Date: Aug 2007
Vehicle: 2003 Ford Mustang GT
Location: MO/ Born and raised in Louisiana
Posts: 9,809
Default

Hey man good info but this is like a 5 mth old post! Hopefully the OP took care of it by now.
__________________



Vortech V-1 T Trim SC (intercooled)
HP 292 cams
Teksid Forged Short Block 433 RWHP/390 RWTQ 3.33 pulley
New Project: MMR 900 Shortblock/2.87 pulley/465 RWHP or bust!
Soldier GT is offline   Reply With Quote
Old 03-16-2014, 07:36 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 01:34 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup