I have returned. - Page 2 - MustangForums.com


4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-25-2014, 12:42 AM   #11
UPRSharad
Sponsor
 
UPRSharad's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 2,568
Default

Quote:
Originally Posted by PurpleIcedGT View Post
Nothing is really new. Whitefox is back into a Lightning, Sharad still owns the sexiest coyote, Crash still has an insanely slow 2v, I still drive an Altima and am getting married next summer, Kugz is skinny, and #thats #about #it.
UPRSharad is offline   Reply With Quote
Old 07-25-2014, 10:25 AM   #12
uberstang1
Chupacabra
Thread Starter
 
uberstang1's Avatar
 
Join Date: Jul 2004
Location: wilkes-barre PA
Posts: 9,612
Default

Nice lol
uberstang1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Extremely disappointing order and service. JDWalton AmericanMuscle.com 27 04-19-2016 07:24 PM
Possible Clutch Issues..? Thunderball 4.6L (1996-2004 Modular) Mustang 15 11-23-2015 12:49 AM
DIY A/C repair MustangMan1718 2005-2014 Mustangs 4 06-28-2015 10:25 PM
289 STILL with heat soak issues Diputado Classic Mustangs (Tech) 13 11-25-2014 01:21 PM
Need help on Purchase please! Snake6778 SVT Forums 1 12-31-2007 05:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:23 AM.