Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-01-2009, 11:38 AM   #1
Bobert
3rd Gear Member
 
Join Date: Dec 2007
Vehicle: 1990 Lx
Location:
Posts: 717
Default ERV Is messed up. Help!

So this is like my 6th thread dealing with my idle. So now the problem is the car will start up, have the engine light on and it will rev at like 1500. Then when i bang all the solenoids behind the passenger strut tower the idle drops to 800, which is what i set it at.

So even one time when i had the hood opened cause i was checking something, and it was reving at 1500, when i dropped the hood to shut it, the car started to idle fine :l

Is this the entire unit issue? Or a sketch vacuum leak? I tried propane for like the 10th time. No luck.

My next question i also have an issue with an idle roll when its at 1500, can this be caused by the EVR?

Thanks guys!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
Materials Engineering Graduate from McMaster University -

1990 5.0L Lx, stock
There's no replacement for displacement.

"If you ask one more time about getting a larger maf... I will drive out to pennsylvania and push your car into a pond..." RIP AdderMK2
Bobert is offline   Reply With Quote
Old 07-01-2009, 02:31 PM   #2
gt884me
2nd Gear Member
 
gt884me's Avatar
 
Join Date: Feb 2006
Vehicle: 1988 GT
Location: Iowa
Posts: 474
Default

If the engine light comes on, did you pull codes? Might want to start there
__________________
]
gt884me is offline   Reply With Quote
Old 07-01-2009, 04:02 PM   #3
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Vehicle: 1986 Ford Mustang GT
Location: Puerto Rico
Posts: 3,926
Default

You could disconnect the EVR and smog solenoids, and the CEL shouldn't turn on. As mentioned above, start by running the DIY KOEO/KOER self tests. LUK
__________________
ACRONYMS:
LUK=Let Us Know, GL=Good Luck, LMK=Let Me Know, JIC=Just In Case, BTSTDTRT=Been There Seen That Done That Repaired That, YCYDYP=Your Car Your Dough Your Prerogative and the classic... DILLIGAS=Do I Look Like I Give A S***

1986 GT-X303-289 heads-1.72 rockers-RG 4+1 Trans.
Quote:
Originally Posted by Joel5.0
Great thoughts will overwhelm a feeble mind.
There is never money to do it right, but there's always money to do it over.
The proof of understanding is the ability to explain it. (H. Torruella)
Joel5.0 is offline   Reply With Quote
Old 07-01-2009, 05:52 PM   #4
Bobert
3rd Gear Member
 
Join Date: Dec 2007
Vehicle: 1990 Lx
Location:
Posts: 717
Default

Already ran the test, nothing out of the ordinary, just the 2 for having no cats and the 1 cause i didnt let the engine warm up enough.

Forgot to mention that

Also the engine light doesnt stay on all the time.

I can shut the car off and start it up and it will be fine. 5 mins down the road it will act up, light on, 30 secs later lights off.

eo didnt help w/ any codes
__________________
Materials Engineering Graduate from McMaster University -

1990 5.0L Lx, stock
There's no replacement for displacement.

"If you ask one more time about getting a larger maf... I will drive out to pennsylvania and push your car into a pond..." RIP AdderMK2
Bobert is offline   Reply With Quote
Old 07-01-2009, 06:59 PM   #5
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Vehicle: 1986 Ford Mustang GT
Location: Puerto Rico
Posts: 3,926
Default

Post the code numbers, the fact that you have the CEL turning on = at least a failure code has to be showing in KOEO memory. LUK
__________________
ACRONYMS:
LUK=Let Us Know, GL=Good Luck, LMK=Let Me Know, JIC=Just In Case, BTSTDTRT=Been There Seen That Done That Repaired That, YCYDYP=Your Car Your Dough Your Prerogative and the classic... DILLIGAS=Do I Look Like I Give A S***

1986 GT-X303-289 heads-1.72 rockers-RG 4+1 Trans.
Quote:
Originally Posted by Joel5.0
Great thoughts will overwhelm a feeble mind.
There is never money to do it right, but there's always money to do it over.
The proof of understanding is the ability to explain it. (H. Torruella)
Joel5.0 is offline   Reply With Quote
Old 07-01-2009, 07:48 PM   #6
mjr46
Wal-mart lube/tire tech
 
mjr46's Avatar
 
Join Date: Jun 2007
Vehicle: 85 mustang
Location: West Virginia
Posts: 29,891
Default

catalyst is not monitored on obd1 so you shouldn't have any codes for cats
__________________

Quote:
Originally Posted by dudegirl View Post
Be polite and cordial when you talk to them, as pissing off the guys that can help you is seldom a good idea.
mjr46 is offline   Reply With Quote
Old 07-02-2009, 12:33 PM   #7
Bobert
3rd Gear Member
 
Join Date: Dec 2007
Vehicle: 1990 Lx
Location:
Posts: 717
Default

Ok this is how she went down

Eo test without car being started for 2 days.

turn key
clicky sounds from pass side of engine bay
light flickers a bit
4 flashes for v8
long pause
flash
long pause
41 - System Indicates Lean -passenger side(R), No o2 Sensor Switching Detected. always lean -passenger side(M)
63 - Throttle Position Sensor Circuit Below Minimum Voltage (O,M,R)
91 - o2 Sensor Circuit Indicates Lean -driver side(R), No o2 Sensor Switching Detected. always lean -driver side(M), Shift Solenoid 1 Circuit Failure (O)


I have already posted about these 3 codes, and did everything i was told to do. I erased the codes, re set the idle and re did the tps its fine i ahve no idea why i keep getting that code.

I know my car runs lean. It is what is causing my rough idle, a vacuum leack which i cannot find. I believe its caused by this EVR.

I have checked the EGR and chased the entire car with propane.

I have pulled the plugs, there white, im lean,.

I need to know why i am lean.
__________________
Materials Engineering Graduate from McMaster University -

1990 5.0L Lx, stock
There's no replacement for displacement.

"If you ask one more time about getting a larger maf... I will drive out to pennsylvania and push your car into a pond..." RIP AdderMK2
Bobert is offline   Reply With Quote
Old 07-02-2009, 12:34 PM   #8
Bobert
3rd Gear Member
 
Join Date: Dec 2007
Vehicle: 1990 Lx
Location:
Posts: 717
Default

i also have brand new 02s
and im running an o/r h pipe
__________________
Materials Engineering Graduate from McMaster University -

1990 5.0L Lx, stock
There's no replacement for displacement.

"If you ask one more time about getting a larger maf... I will drive out to pennsylvania and push your car into a pond..." RIP AdderMK2
Bobert is offline   Reply With Quote
Old 07-02-2009, 01:02 PM   #9
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Vehicle: 1986 Ford Mustang GT
Location: Puerto Rico
Posts: 3,926
Default

Eo as in KOEO (Key On Engine Off)?.....
__________________
ACRONYMS:
LUK=Let Us Know, GL=Good Luck, LMK=Let Me Know, JIC=Just In Case, BTSTDTRT=Been There Seen That Done That Repaired That, YCYDYP=Your Car Your Dough Your Prerogative and the classic... DILLIGAS=Do I Look Like I Give A S***

1986 GT-X303-289 heads-1.72 rockers-RG 4+1 Trans.
Quote:
Originally Posted by Joel5.0
Great thoughts will overwhelm a feeble mind.
There is never money to do it right, but there's always money to do it over.
The proof of understanding is the ability to explain it. (H. Torruella)
Joel5.0 is offline   Reply With Quote
Old 07-02-2009, 04:56 PM   #10
Bobert
3rd Gear Member
 
Join Date: Dec 2007
Vehicle: 1990 Lx
Location:
Posts: 717
Default

yeea koeo
__________________
Materials Engineering Graduate from McMaster University -

1990 5.0L Lx, stock
There's no replacement for displacement.

"If you ask one more time about getting a larger maf... I will drive out to pennsylvania and push your car into a pond..." RIP AdderMK2
Bobert is offline   Reply With Quote
Old 07-02-2009, 04:56 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
erv, mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:00 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup