Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-01-2005, 06:25 PM   #1
jachunter
 
Join Date: Aug 2005
Posts: 18
Default Help my horse!

Alright, I put the post up a few days ago on the 5.0 that misses, skips and doesn't respons only when floored or punched.

I changed all the plugs, wires, rotor & cap. No change.

Engine is running a little hot...Plugs were white.


Any ideas what I can try next to get this thing to respons to full throttle?

I had compression checked --All over 130

I had diagnositc test done - No problems.

Still, it is slower than the camry that wasn't even trying to race me today!

This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
jachunter is offline   Reply With Quote
Old 09-01-2005, 06:30 PM   #2
jachunter
 
Join Date: Aug 2005
Posts: 18
Default RE: Help my horse!

94GT

You name the problem that fixes it and I'll but you a part off ebay for your stang. Up to 100 bucks.
jachunter is offline   Reply With Quote
Old 09-01-2005, 07:27 PM   #3
wildstang87
2nd Gear Member
 
Join Date: Jul 2005
Location:
Posts: 466
Default RE: Help my horse!

tps, unplug it and take it for a drive, cant wait for my new part.
wildstang87 is offline   Reply With Quote
Old 09-01-2005, 07:54 PM   #4
jachunter
 
Join Date: Aug 2005
Posts: 18
Default RE: Help my horse!

just unplugged the tps. it idled a lot worse when unplugged and actually stuttered and shut down worse when floored...

did you see my previous post that went into more detail?

thank for the try.

im desperate and will deliver on the promise
jachunter is offline   Reply With Quote
Old 09-01-2005, 09:00 PM   #5
90GTRagtop
2nd Gear Member
 
Join Date: Sep 2004
Posts: 394
Default RE: Help my horse!

Have you pulled the codes to see if anything is stored? That's usually a good start. Might try cleaning your Mass Air Flow (MAF) and your Idle Air Control (IAC). If these aren't responding correctly it may be leaning out when you punch it.
90GTRagtop is offline   Reply With Quote
Old 09-01-2005, 09:42 PM   #6
jachunter
 
Join Date: Aug 2005
Posts: 18
Default RE: Help my horse!

I had a diagnositc run by a mechanic shop...>He said the only problem was the o2 sensor but that was because i have an hpipe that is cat free.

How would clean the maf and iac? do you mean clean off the connections and blow out the female end?

thanks 90gt

Just to recap it runs great except when you punch it...When you punch it, it feels like a 4 cylinder.

It revs however, like a champ (not in gear)
jachunter is offline   Reply With Quote
Old 09-01-2005, 10:14 PM   #7
90GTRagtop
2nd Gear Member
 
Join Date: Sep 2004
Posts: 394
Default RE: Help my horse!

Check out these links;
IAC cleaning http://www.muscularmustangs.com/iac.php
MAF cleaning http://www.muscularmustangs.com/maf.php

Since it is popping and lacking power under sudden acceleration under load but accelerates OK when not loaded, my thought is that it may be slightly fuel starved. Like if the IAC is open for Idle and doesn't close quick enough, or if the MAF response is just slow.
90GTRagtop is offline   Reply With Quote
Old 09-01-2005, 10:27 PM   #8
ACE
4th Gear Member
 
Join Date: Jul 2005
Vehicle: 90 notch
Location:
Posts: 1,209
Send a message via AIM to ACE
Default RE: Help my horse!

hey quick question is the stang auto or stick? if its auto does it kick down into passing gear when you hit it or does it just keep bogging? maybe its not kicking down
__________________

Windsor powah!
1985 GT 1986 GT sunroof 1986 GT T-top 90 notch and a side of a yellow vert
ACE is offline   Reply With Quote
Old 09-01-2005, 11:34 PM   #9
sick95gt
2nd Gear Member
 
Join Date: May 2005
Location:
Posts: 275
Default RE: Help my horse!

maybe the injectors are dirty. Try the fuel filter too.
__________________
331, Pro Products manifold (performer knock off), dart pro1 heads, f303 cam, 24# inj., 190 lph pump, BBK fpr, 76mm c&l maf and tru flow pipe, 70mm tb, BBK headers, bassani x-pipe w/cats, mac 2.5 catback, MSD 6al ignition, MSD coil, cap and rotor, 4.10's, u/d pulleys, FRPP aluminum driveshaft, rear control arms, Eibach prokit, KYB shocks/struts, Steeda c/c plates, Tri-ax shifter....
sick95gt is offline   Reply With Quote
Old 09-02-2005, 12:12 AM   #10
jachunter
 
Join Date: Aug 2005
Posts: 18
Default RE: Help my horse!

just changed the fuel filter...it was filthy...still no different...idle seems to be a little lower ( around 600 now )

i ran 93 octane and fuel injector cleaner through it on my first tank since i bought it.

getting ready to clean the maf and iac
jachunter is offline   Reply With Quote
Old 09-02-2005, 12:12 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
bb1211, ignition, module

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My horse aint kickin' over!! kramrkixass Classic Mustangs (Tech) 10 03-11-2006 01:55 PM
help my front end is too low!!!!!!!!!!! bb1211 4.6L (1996-2004 Modular) Mustang 17 12-17-2005 11:21 PM

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 11:14 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup