In need of help -

Go Back > Ford Mustang Tech > General Tech

General Tech Ask model specific questions in the appropriate category below. All other general questions within.
Sponsored by NewTakeOff

In need of help

Thread Tools Search this Thread
Old 05-18-2013, 08:51 PM   #1
Join Date: May 2013
Vehicle: 2003 mustang gt
Location: Florida
Posts: 3
Default In need of help

In need of help
I have a full bolted stock motor on a 125 wet shot
Went out last night had a few runs car ran perfect
On the way home I got one last run in, ten minutes later
A shotgun sound happend, waited til morning, checked
Intake manifold cause I have blow a hole in one before due to
A backfire, this time I could a +fist size hole in my valve cover
And motor won't turn, but under valve looks perfect, all fluids are
Perfect and where they should be, car did not over heat and did not lose
Oil or oil pressure and plugs were also fine, any ideas??
Auto2v is offline   Reply With Quote


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:25 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company