Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Automatic transmission lag on takeoff?

Old 08-20-2015, 10:58 PM
  #1  
kdryan
2nd Gear Member
Thread Starter
 
kdryan's Avatar
 
Join Date: Jan 2013
Location: Indiana
Posts: 260
Default Automatic transmission lag on takeoff?

Ok, so I've had my 2013 GT for a few days now and I notice there's a lag in standard drive when I take off. I understand this is a pretty common annoyance and have heard it can be fixed with a different tune. Can someone point me in the direction to get this done? I don't feel confident enough to do it myself, so I'll be taking it someplace.

Thanks!
kdryan is offline  
Old 08-21-2015, 07:11 AM
  #2  
99GTvert
is my username.
 
99GTvert's Avatar
 
Join Date: May 2006
Location: Earth
Posts: 13,779
Default

A new tune can be acquired by simply purchasing a handheld tuner from a forum vendor (they make the tune and load onto the handheld tuner) and mailed to you. You can upload to your car by yourself. On my 99 I just plugged it in to the car's OBD2 port and followed the directions. I think its still very similar on the newer cars.

You can also find a local shop and have it dyno tuned instead.
99GTvert is offline  
Old 08-21-2015, 07:10 PM
  #3  
harleycharlie
 
harleycharlie's Avatar
 
Join Date: Jul 2015
Location: ca
Posts: 38
Default

I had that lag in my '14 gt. felt more like throttle response issue. theres a box that plugs into the throttle pedal and takes that all away, and its adjustable. Its from JMS called a "pedalmax" works perfectly on mine, quicker throttle response, gas mileage suffers a bit, but not bad. I don't think you're feeling the trans, most likely throttle lag


http://www.jmschip.com/pedalmax-2011...ford-vehicles/
harleycharlie is offline  
Old 08-21-2015, 09:47 PM
  #4  
kdryan
2nd Gear Member
Thread Starter
 
kdryan's Avatar
 
Join Date: Jan 2013
Location: Indiana
Posts: 260
Default

Originally Posted by harleycharlie View Post
I had that lag in my '14 gt. felt more like throttle response issue. theres a box that plugs into the throttle pedal and takes that all away, and its adjustable. Its from JMS called a "pedalmax" works perfectly on mine, quicker throttle response, gas mileage suffers a bit, but not bad. I don't think you're feeling the trans, most likely throttle lag


http://www.jmschip.com/pedalmax-2011...ford-vehicles/
Good cal! Thanks!
kdryan is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
b8checker
Classic Mustangs (Tech)
8
10-08-2015 12:55 PM
guitarman376
4.6L (1996-2004 Modular) Mustang
0
09-30-2015 05:54 PM
b8checker
New Member Area
3
09-30-2015 07:11 AM
wraith777
General Tech
1
09-28-2015 10:49 AM


Thread Tools
Search this Thread
Quick Reply: Automatic transmission lag on takeoff?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.