Power outlet in center console not working - MustangForums.com



4.0L V6 Technical Discussions Any questions about engine, transmission, exhaust, tuners/CAI, or gearing can be asked here!
Sponsored by:
Sponsored by:

     
Old 10-22-2015, 07:00 PM
How-Tos on this Topic
 
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Ford Mustang Interior Guides
Print Wikipost

Reply
 
 
 
Thread Tools Search this Thread
Old 03-30-2011, 11:35 PM   #1
Hotwheelracer
3rd Gear Member
Thread Starter
 
Hotwheelracer's Avatar
 
Join Date: Mar 2011
Location: Nevada
Posts: 501
Default Power outlet in center console not working

Just got the car a month ago, tried to plug my charger in the power oulet in the center console, no power. Works fine from the one in the dash. Is this a fuse issue? Would there be a fuse dedicated to just this outlet because everything else works?
Hotwheelracer is offline   Reply With Quote
Old 03-31-2011, 07:40 AM   #2
pat6674u
3rd Gear Member
 
Join Date: Mar 2006
Location: Rancho Cucamonga, CA
Posts: 856
Default

I can tell you the fuse for the dash plug and center comp plug are separate, as I had the opposite happen with my car. Pull the fuse for the dash and replace. Otherwise it could be unplugged or just bad.
pat6674u is offline   Reply With Quote
Old 03-31-2011, 09:03 AM   #3
obxdude018
3rd Gear Member
 
obxdude018's Avatar
 
Join Date: Jul 2009
Location: Garner NC
Posts: 765
Default

It's most likely the fuse, another possibility if someone removed the center console before they could of forgotten to hook up the connection for the 12v outlet
obxdude018 is offline   Reply With Quote
Old 03-31-2011, 10:07 AM   #4
Hotwheelracer
3rd Gear Member
Thread Starter
 
Hotwheelracer's Avatar
 
Join Date: Mar 2011
Location: Nevada
Posts: 501
Default

Thanks for the advice gentlemen, I will fiddle with it this weekend.
Hotwheelracer is offline   Reply With Quote
Old 03-31-2011, 12:03 PM   #5
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

http://iihs.net/fsm/?dir=40&viewfile...ar Lighter.pdf

The 2nd sheet shows both fuses at the BEC.
Nuke is offline   Reply With Quote
Old 04-06-2011, 09:28 PM   #6
Twstones
2nd Gear Member
 
Twstones's Avatar
 
Join Date: Jul 2009
Location: Illinois
Posts: 219
Default

In case you haven't check, the center consul is fuse #64, and the dash power point is fuse #61 Both are in the power distribution box, under the hood, and they're both 20 amp.
Twstones is offline   Reply With Quote
Old 04-11-2011, 10:07 PM   #7
DansZJ
 
Join Date: Jan 2011
Location: AZ
Posts: 5
Default

Thanks guys. I had the same issue with the center console. I had checked the connections this weekend and was going to replace the socket. It was just a blown fuse. Save me money & time.
DansZJ is offline   Reply With Quote
Old 04-11-2011, 10:17 PM   #8
05windviel
2nd Gear Member
 
05windviel's Avatar
 
Join Date: Mar 2008
Location: Iowa
Posts: 289
Default

also be sure to keep the plug on it because sometimes coins can get inside of the socket and cause the fuse to blow thats why they have the nifty cover
05windviel is offline   Reply With Quote
Old 04-12-2011, 03:03 PM   #9
Hotwheelracer
3rd Gear Member
Thread Starter
 
Hotwheelracer's Avatar
 
Join Date: Mar 2011
Location: Nevada
Posts: 501
Default

Quote:
Originally Posted by 05windviel View Post
also be sure to keep the plug on it because sometimes coins can get inside of the socket and cause the fuse to blow thats why they have the nifty cover
Ding, Ding, Ding, we have a winner!. Checked my outlet, darm Abraham Lincoln stuck in there. Pulled him out with some tape and a pencil. And now the outlet works. Man did I feel dumb for this being such an obvious thing to check.

Thanks for pointing this out, I like using this outlet much better to charge my phone as opposed to the on in the dash.
Hotwheelracer is offline   Reply With Quote
Old 04-12-2011, 11:04 PM   #10
05windviel
2nd Gear Member
 
05windviel's Avatar
 
Join Date: Mar 2008
Location: Iowa
Posts: 289
Default

Quote:
Originally Posted by Hotwheelracer View Post
Ding, Ding, Ding, we have a winner!. Checked my outlet, darm Abraham Lincoln stuck in there. Pulled him out with some tape and a pencil. And now the outlet works. Man did I feel dumb for this being such an obvious thing to check.

Thanks for pointing this out, I like using this outlet much better to charge my phone as opposed to the on in the dash.
no prob its really easy for one to get in there and its hard to tell if there is because its in the console
05windviel is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003-2004 SVT Cobra Fog Light LED Bulbs! Plug & Play install! See Comparison Photos! Diode Dynamics Vendor For Sale / Group Buy Classifieds 4 11-28-2016 11:14 PM
Lethal Performance Exhaust is On SALE!! Boostaddict Lethal Performance 1 09-15-2015 04:17 PM
Win a $1500 MMD Styling Package- AmericanMuscle AMWill AmericanMuscle.com 26 09-08-2015 01:32 PM
T56 Spline Shafts NOW IN STOCK @ LethalPerformance.com! Boostaddict Lethal Performance 0 08-13-2015 01:57 PM
One Day Only! FREE SHIPPING No Minimum! [email protected] Detailing 0 08-05-2015 12:33 PM


Tags
08, 1994, 2005, 2011, 95, broken, car, center, console, fuse, gt, mustang, outlet, position, power, s197, seats, working, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 03:29 PM.