HOT!! :( - MustangForums.com

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

HOT!! :(

Reply

 
 
 
Old 09-01-2011, 12:44 AM
  #1  
RoushRacerDB
Thread Starter
 
Join Date: Sep 2011
Location: Colorado
Posts: 2
Default HOT!! :(

I had a new clutch put in a few months ago and ever since then theres been a lot of heat coming out from near the pedals. It seems to be getting worse and everyone I talk to really doesn't have much of an answer for me. I just need to know what the problem is or even how I can fix i without having to take it in and get it looked at. Thanks
RoushRacerDB is offline  
Reply With Quote
Old 09-01-2011, 01:19 AM
  #2  
Repzard
4th Gear Member
 
Repzard's Avatar
 
Join Date: Apr 2009
Location: sttesuhcaxaT (The State you love to hate)
Posts: 1,360
Default

If its clutch issue, Im "guessing " warped or bad surface on flywheels?
To me im thinking it more to do with heater flap in heating system.



Is there any type of burning smells when it gets hot?
Is car running good? if not cats heating up cherry heating your foot area?

Just tossing a few ideas out there. GL
Repzard is offline  
Reply With Quote
Old 09-01-2011, 06:19 AM
  #3  
uberstang1
Chupacabra
 
uberstang1's Avatar
 
Join Date: Jul 2004
Location: wilkes-barre PA
Posts: 9,615
Default

Its a possibility when the shop dropped the mid pipe and the tranny there could be a few things wrong, exhaust leak, the heat shield from the transmission tunnel could never been put back, or the shield could of been ripped. I would wait till you are through the break in period of the clutch before suspecting thats the problem. Is it slipping?
uberstang1 is offline  
Reply With Quote
Old 09-01-2011, 08:36 AM
  #4  
RoushRacerDB
Thread Starter
 
Join Date: Sep 2011
Location: Colorado
Posts: 2
Default

The clutch works fine except for a few noises, and luckily there's not a burning smell when it gets hot. I'm guessing it is probably the heat shield cause the guy already had to fix a mistake he made in putting the car back together after putting the clutch in.

How big of an issue is it if the heat shield wasn't replaced or is ripped??
RoushRacerDB is offline  
Reply With Quote
Old 09-01-2011, 02:41 PM
  #5  
amoosenamedhank
5th Gear Member
 
amoosenamedhank's Avatar
 
Join Date: Nov 2005
Location: MN
Posts: 4,418
Default

My car was like a furnace all the damn time. I figured it was from the long tubes but who knows.
amoosenamedhank is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bradleyb
Classic Mustangs (Tech)
3
11-27-2015 08:50 PM
88 orangepeel notch
Street/Strip
4
10-05-2015 10:03 AM
jrrhd73must
Classic Mustang General Discussion
2
10-02-2015 10:17 PM
AMAlexLazarus
AmericanMuscle.com
0
10-01-2015 10:21 AM
bradleyb
California Regional Chapter
0
10-01-2015 02:02 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory