Problem in Rain - MustangForums.com

Notices
General Tech Ask model specific questions in the appropriate category below. All other general questions within.

Problem in Rain

Reply

 
 
 
Old 10-23-2007, 10:31 PM
  #1  
20Mustang00
1st Gear Member
Thread Starter
 
Join Date: Sep 2007
Posts: 138
Default Problem in Rain

This isn't the first time I've noticed this but it has been raining the last couple of days and when i hit a water puttle my power in my car seems to go down... the needle for the battery stays normal but the lights will go dim and the inside lights will go dim... and the windshield wipers will slow down.. is this normal..?
20Mustang00 is offline  
Reply With Quote
Old 10-24-2007, 01:10 AM
  #2  
35thanniz28
 
Join Date: Oct 2007
Location:
Posts: 8
Default RE: Problem in Rain

its completely normal...for rustangs to break down like that...
35thanniz28 is offline  
Reply With Quote
Old 10-24-2007, 01:40 AM
  #3  
bmennen07
2nd Gear Member
 
Join Date: Jun 2007
Location:
Posts: 220
Default RE: Problem in Rain

no its not normal. well...in that guys gaymaro maby but water is prob getting somewhere it shouldnt be.
bmennen07 is offline  
Reply With Quote
Old 10-24-2007, 01:53 AM
  #4  
OnyxCobra
6th Gear Member
 
OnyxCobra's Avatar
 
Join Date: Nov 2005
Location: Rochester, NY
Posts: 8,467
Default RE: Problem in Rain

ORIGINAL: 35thanniz28

its completely normal...for rustangs to break down like that...
you are obviously a retard. I've never had that problem, something might be shorting out, not really sure. It's only when you hit a puddle?
OnyxCobra is offline  
Reply With Quote
Old 10-24-2007, 07:41 AM
  #5  
GreyStang
5th Gear Member
 
Join Date: Apr 2005
Location:
Posts: 3,062
Default RE: Problem in Rain

The gaymaros mullet probably is blocking his view to give decent advice.

How long does this "power loss" last for? Yup you've probably got a short somewhere which might be tough to track down.

Next sunny day, try idling your car in your driveway & spray a garden hose around underneath the car,, see if you can make it happen that way & what spot did the problem show up at.
GreyStang is offline  
Reply With Quote
Old 10-24-2007, 03:45 PM
  #6  
kennebellgt
2nd Gear Member
 
kennebellgt's Avatar
 
Join Date: Apr 2007
Location:
Posts: 368
Default RE: Problem in Rain

check your starter cable which is the pos+ to your car it may be loose also check for exposed wiring on the + that would also cause it, you dont want to drive around in the rain too much its only a matter of time before you fry your entire electrical harness.
kennebellgt is offline  
Reply With Quote
Old 10-24-2007, 10:14 PM
  #7  
20Mustang00
1st Gear Member
Thread Starter
 
Join Date: Sep 2007
Posts: 138
Default RE: Problem in Rain

yeah... its only when i hit a puddle... and it last for about 2-5 secs..... depending on how hard or how big the puddle is or is hit.....
20Mustang00 is offline  
Reply With Quote
Old 10-24-2007, 10:29 PM
  #8  
xpvuey239w
1st Gear Member
 
Join Date: Oct 2007
Location:
Posts: 63
Default RE: Problem in Rain

ORIGINAL: 35thanniz28

its completely normal...for rustangs to break down like that...
it seems by all your annoying posts that your a chevy fan try this forum instead
www.imadouchebagandilovepenis-forum.com
i may be a newb but i know what this web site is made for
its made for ford enthusiasts not chevy people
i have nothing against chevy people everyone has there thing
but do your thing somehwere else.
xpvuey239w is offline  
Reply With Quote
Old 10-25-2007, 01:56 AM
  #9  
ninelives19821
2nd Gear Member
 
Join Date: Mar 2007
Location: Washington
Posts: 188
Default RE: Problem in Rain

ORIGINAL: 35thanniz28

its completely normal...for rustangs to break down like that...
[&:].... I love Chevys, but don't act like they never break or have problems just like every other car. The guy just needs some help you big asshat.

Try to slow down when you hit the puddle until you get it fixed. The water is just getting somewhere in your electrical system it's not supposed to get access to. I could be wrong, but mabey the water is getting the alternator belt wet and causing slippage for a brief time. But if that was the case i dont know why the amp meter is not moving.
ninelives19821 is offline  
Reply With Quote
Old 10-28-2007, 04:16 PM
  #10  
20Mustang00
1st Gear Member
Thread Starter
 
Join Date: Sep 2007
Posts: 138
Default RE: Problem in Rain

Also, i forgot to add, that right before it goes back to normal, there is teh loud squeaking noise for only about 2 seconds.... don't know if that helps any..
20Mustang00 is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Problem in Rain


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.