Vents smell like crap, help please. - MustangForums.com


General Tech Ask model specific questions in the appropriate category below. All other general questions within.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-20-2008, 05:00 PM   #1  
Clu7ch
5th Gear Member
Thread Starter
 
Clu7ch's Avatar
 
Join Date: Mar 2006
Location: Where I lay my head is home
Posts: 2,328
Default Vents smell like crap, help please.

So, as the title states, the vents in my car smell like crap when I have them on bringing outside air into the car. If I have the a/c on and it circulating the air over and over, it doesn't smell bad. Any suggestions on cleaning it or making it not smell anymore?

-Clu7ch
Clu7ch is offline   Reply With Quote
Old 08-20-2008, 05:19 PM   #2  
ewgoetz
3rd Gear Member
 
Join Date: Nov 2007
Location: Venice, FL
Posts: 912
Default

Either some mold/fungus settled in there or something crawled up in there and died.
you can either get a can of lysol and spray the entire can in the ouside vent whil it is on and blowing. If that does not solve the issue chances are something crawled up there and died. In that case you will have to take apart the vent system to get it out.
ewgoetz is offline   Reply With Quote
Old 08-20-2008, 08:46 PM   #3  
nymustangGT
 
Join Date: Aug 2007
Location:
Posts: 28
Default

Quote:
Originally Posted by Clu7ch View Post
So, as the title states, the vents in my car smell like crap when I have them on bringing outside air into the car. If I have the a/c on and it circulating the air over and over, it doesn't smell bad. Any suggestions on cleaning it or making it not smell anymore?

-Clu7ch
I had the same problem with my car shortly after the winter , I never found out what it was however u r right it stunk like something crawled into the vents and died. suggestion run the vents for a while and it will go away i did this for about 2 weeks and it finally went away . Also did you notice the smell is not present when you have the temp up( heat) ?
nymustangGT is offline   Reply With Quote
Old 08-21-2008, 05:27 PM   #4  
Clu7ch
5th Gear Member
Thread Starter
 
Clu7ch's Avatar
 
Join Date: Mar 2006
Location: Where I lay my head is home
Posts: 2,328
Default

I don't believe it smells when the heat is on. It has been several weeks, so it's not just going away. I sprayed some fabreeze in there a long while ago. Didn't do much, almost seems it made it a little worse.

Well, on to the next step, Lysol. If that doesn't work, I'll be posting pics of what was in there. LOL!
Clu7ch is offline   Reply With Quote
Old 08-21-2008, 07:32 PM   #5  
ewgoetz
3rd Gear Member
 
Join Date: Nov 2007
Location: Venice, FL
Posts: 912
Default

Use Lysol its a disinfectant and will kill mold if there is any in there. fabreeze will just cover the smell up or make it worse.
ewgoetz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Upgraded PaulH2 Members Rides and Car Show Section 20 01-31-2016 09:48 AM
Vintage AC shop referral - frontrunner serpentine system bradleyb Classic Mustangs (Tech) 3 11-27-2015 07:50 PM
I should've known better ChampInSD 5.0L GT S550 Tech 13 10-02-2015 04:55 AM
Vintage AC shop referral in los angeles bradleyb California Regional Chapter 0 10-01-2015 01:02 AM
Please help! 10 Check engine codes mrtrodonet V6 (1994-2004) Mustangs 1 09-29-2015 11:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:22 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.