AMP. PROBLEMS - MustangForums.com

General Tech Ask model specific questions in the appropriate category below. All other general questions within.

AMP. PROBLEMS

Reply

 
 
 
Old 12-14-2003, 08:50 PM
  #1  
BLKSTANG9879
4th Gear Member
Thread Starter
 
Join Date: Dec 2003
Location: United States
Posts: 1,128
Default AMP. PROBLEMS



I WAS DRIVING DOWN THE STREET. I HIT A FRIGGIN POT-HOLE. THEN MY AMP JUST SHUT DOWN. (THIS WAS A MOUNTH AGO). LAST NIGHT I WAS IN A STREET RACE. IN THE MIDDLE OF THE RACE THE AMP. CAME BACK ON. TODAY I CHECKED ALL THE CONNECTIONS. I EVEN TOOK THE AMP APART TO LOOK FOR SOMETHING THAT CAME LOOSE. I DIDN'T FIND A THING. SHOULD I TRASH IT, OR IS IT WORTH IT TO GET IT FIXED.</P>
BLKSTANG9879 is offline  
Reply With Quote
Old 12-14-2003, 09:33 PM
  #2  
SilverGTV8
4th Gear Member
 
Join Date: Aug 2003
Location: United States
Posts: 1,974
Default AMP. PROBLEMS

Sounds like you amp trigger switch wire might be causing it to shut down. Jiggle the wires and perhaps chase that one through the car and see if is kinked, cut, pinched or anything.
SilverGTV8 is offline  
Reply With Quote
Old 12-14-2003, 09:55 PM
  #3  
Dan04COBRA
Super Moderator
 
Join Date: Jul 2003
Location:
Posts: 14,917
Default AMP. PROBLEMS

I'm with SilverGT on this, I had an identical problem.
Dan04COBRA is offline  
Reply With Quote
Old 12-14-2003, 10:13 PM
  #4  
BLKSTANG9879
4th Gear Member
Thread Starter
 
Join Date: Dec 2003
Location: United States
Posts: 1,128
Default AMP. PROBLEMS



Originally Posted by SilverGTV8
Sounds like you amp trigger switch wire might be causing it to shut down. Jiggle the wires and perhaps chase that one through the car and see if is kinked, cut, pinched or anything.
</P>


YEAH I TRIED THAT. I THINK THE AMP. JUST TOOK A SH&amp;% ON ME. </P>
BLKSTANG9879 is offline  
Reply With Quote
Old 12-14-2003, 10:33 PM
  #5  
SilverGTV8
4th Gear Member
 
Join Date: Aug 2003
Location: United States
Posts: 1,974
Default AMP. PROBLEMS

did you jump start the car at anytime with the radio on? or jump someone elses car? I had a friend loose an amp after getting his car jumped.
SilverGTV8 is offline  
Reply With Quote
Old 12-14-2003, 10:35 PM
  #6  
Dan04COBRA
Super Moderator
 
Join Date: Jul 2003
Location:
Posts: 14,917
Default AMP. PROBLEMS

Damn!! I smokedtheamp in my Iroc-z the same way!
Dan04COBRA is offline  
Reply With Quote
Old 12-14-2003, 10:45 PM
  #7  
SilverGTV8
4th Gear Member
 
Join Date: Aug 2003
Location: United States
Posts: 1,974
Default AMP. PROBLEMS



Weird. His car was an LT1.</P>
SilverGTV8 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
69Volunteer
Classic Mustang General Discussion
1
09-30-2015 10:39 AM
marc954
4.6L General Discussion
8
09-29-2015 03:05 PM
marc954
New Member Area
2
09-25-2015 06:48 AM
stangin1996gt
4.6L (1996-2004 Modular) Mustang
0
09-21-2015 11:01 AM
Big Al's 03
Mach 1 Section
4
09-21-2015 07:59 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory