Evaporator went out - MustangForums.com

Notices
The New S550 2015-2020 Mustang Discussions on the newest generation of the Ford Mustang.

Evaporator went out

Reply

 
 
 
Old 07-25-2016, 11:04 PM
  #1  
n813ca
Thread Starter
 
Join Date: Jun 2015
Location: FL
Posts: 24
Default Evaporator went out

11,000 miles on my 2015 GT and the AC stopped working. It put a white film all over the inside of my windshield. I could swear I was getting headaches when it was happening. No AC in Florida... Ford refused to pay for the expense of a loaner while they are waiting on the part on back order. According to the dealer they have had a bunch coming in with this problem. I asked if the new evaporator is any different and they said no...... They are going to have to rip apart the dash to do it. Anyone else go through this?
n813ca is offline  
Reply With Quote
Old 07-26-2016, 12:07 AM
  #2  
jwog666
5th Gear Member
 
jwog666's Avatar
 
Join Date: Mar 2008
Location: wisconsin
Posts: 2,260
Default

havent seen 1 as of yet. you wont find many companies that will pay for a loaner, if your car is 100% driveable. remember, even though its a tad uncomfortable, ac is not a requirement for driving, no matter what the temp or humidity is. a quick google search for "2015 mustang evaporator failure" turns up nothing to suggest that there is a wide spread issue with evaporators.
jwog666 is offline  
Reply With Quote
Old 07-26-2016, 12:12 AM
  #3  
n813ca
Thread Starter
 
Join Date: Jun 2015
Location: FL
Posts: 24
Default

Originally Posted by jwog666 View Post
havent seen 1 as of yet. you wont find many companies that will pay for a loaner, if your car is 100% driveable. remember, even though its a tad uncomfortable, ac is not a requirement for driving, no matter what the temp or humidity is. a quick google search for "2015 mustang evaporator failure" turns up nothing to suggest that there is a wide spread issue with evaporators.
The dealership told me that this issue has become huge and that is why the evaporator is on back order
n813ca is offline  
Reply With Quote
Old 07-26-2016, 12:19 AM
  #4  
jwog666
5th Gear Member
 
jwog666's Avatar
 
Join Date: Mar 2008
Location: wisconsin
Posts: 2,260
Default

since i cant seem to find any mention of evaporator issues while googling it, i find it hard to believe that there is an actual, "huge issue". nobody on this forum has posted about it, nobody on any forums have posted about it, nobody has issued a recall or tsb, and nobody is bitching wide open on the internet. in a day and age where people bitch about everything, they have been suspiciously quiet concerning the "huge" problems concerning evaporators. its much more likely that the dealer you frequent, is feeding you any line of bull$hit they can to get the heat off of their backs for the backordered part.
jwog666 is offline  
Reply With Quote
Old 07-26-2016, 03:30 PM
  #5  
jz78817
4th Gear Member
 
jz78817's Avatar
 
Join Date: Jul 2011
Location: Michigan
Posts: 1,329
Default

The dealer is selling you a fish story. Evaporators are very uncommon service parts for a year old car, and it's likely they don't have any at all in the distribution chain. They have to wait for the supplier to ship them one out of their normal production stock.
jz78817 is offline  
Reply With Quote
Old 07-28-2016, 08:40 PM
  #6  
Intrepid175
1st Gear Member
 
Join Date: Jun 2016
Location: Texas
Posts: 127
Default

Originally Posted by n813ca View Post
It put a white film all over the inside of my windshield. I could swear I was getting headaches when it was happening.
The white film is probably refrigeration oil. If you think it's bad on the windshield, the real mess will be under the dash. I don't doubt you were getting a headache out of it. Freon and atomized oil are not exactly the greatest things to be breathing.

Hope they get the new one soon. I live on the Texas Gulf Coast. Our weather is very much like yours and I certainly wouldn't want to be without my AC round here this time of year. Did they say what level of backorder it was? I used to work parts at a Lincoln dealer back in the early 80's and the code we never wanted to see was a D99 backorder. That's a national backorder which means "no one" knows when the part will be available.

Good luck,
Steve R.
Intrepid175 is offline  
Reply With Quote
Old 07-30-2016, 11:00 PM
  #7  
n813ca
Thread Starter
 
Join Date: Jun 2015
Location: FL
Posts: 24
Default

They originally said it was going to be a month back order.... Luckily they found the part and it was only a week. All great points guys. Thank you.
n813ca is offline  
Reply With Quote
Old 01-14-2017, 09:53 AM
  #8  
first65
 
Join Date: Jan 2017
Location: FL
Posts: 2
Default Evaporator fail round 2

The first evaporator failed at 17K and now they are replacing the 2nd evaporator at 22K. Hope they have found a new supplier. Also factory replaced entire exhaust system at 5K.

Originally Posted by n813ca View Post
11,000 miles on my 2015 GT and the AC stopped working. It put a white film all over the inside of my windshield. I could swear I was getting headaches when it was happening. No AC in Florida... Ford refused to pay for the expense of a loaner while they are waiting on the part on back order. According to the dealer they have had a bunch coming in with this problem. I asked if the new evaporator is any different and they said no...... They are going to have to rip apart the dash to do it. Anyone else go through this?
first65 is offline  
Reply With Quote
Old 01-16-2017, 07:01 AM
  #9  
darkmach1
4th Gear Member
 
darkmach1's Avatar
 
Join Date: Feb 2008
Location:
Posts: 1,797
Default

Jwog, this is infact a huge issue, google evaporator on M6G. Also the dealer is incorrect, there is a new evaporator from a new supplier.
darkmach1 is offline  
Reply With Quote
Old 01-17-2017, 10:02 AM
  #10  
first65
 
Join Date: Jan 2017
Location: FL
Posts: 2
Default

Does anyone know the manufacturer of the evaporator assembly? Just going by the oem part numbers it appears the part number has changed 4 times Origianally it was FR3Z19850A. Since then there has been a K, P, and the most recent when my evaporator was replaced ended in T.
first65 is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Evaporator went out


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.