Clicking when turning left or right - MustangForums.com


V6 (1994-2004) Mustangs Technical discussions on the 3.8L and 3.9L V6 torque monsters

Reply
 
 
 
Thread Tools Search this Thread
Old 09-20-2015, 07:36 PM   #1  
gagemcc
Thread Starter
 
gagemcc's Avatar
 
Join Date: Sep 2014
Location: California
Posts: 32
Default Clicking when turning left or right

Well I installed new ball joints and tie rod ends on both sides because the originals were dead. The clicking sounds went away for a good bit then returned a day or so later, I remember turning the inner tie rods on accident a good bit; could that have offset something to cause the clicking again and an alignment might fix it? Calling Goodyear tomorrow to figure out pricing. I checked the tie rod ends and ball joints to make they sure they are nice and tight and filled etc and they're good.

Check up: Just checked both tie rod ends for play and it seems the passenger side has quite a bit so I am going to take that side apart and see what I could do.

Check up 2: Well I took a look at everything again, everything is tight and in place and no play; I even checked the inner tie rod ends and they had normal wear and tear but no play in the joint itself. the clicking and or popping only happens when I am at speed and turning but when I am in park only one popping sound occurs 50% of the time I am turning the wheel. When I am in drive and at speed it can pop about three or so times when I turn left and when I turn right it only pops or clicks once 50% of the time. Sorry for the TL;DR and thank you to anybody who responds. Hmmm, could it be strut mounts?

Last edited by gagemcc; 09-21-2015 at 05:29 AM. Reason: Check up
gagemcc is offline   Reply With Quote
Old 09-22-2015, 09:43 AM   #2  
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,528
Default

You should always have front end aligned after doing ball joints and tie rod ends.

Maybe they can find something.
movielover40 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 V6 will not start Beerman309 V6 (1994-2004) Mustangs 2 09-19-2015 01:16 AM
New member, need some help. degner122 V6 (1994-2004) Mustangs 2 09-16-2015 07:09 AM
Steeda & Nitto Tire Testing NT555 G2 - Great Photos Inside!! [email protected] Steeda Autosports 0 09-08-2015 11:50 AM
Noise when turnning left Jose Corretjer New Member Area 2 09-08-2015 06:32 AM
Weird electrical/battery issue?? Mobiusone stang 2005-2014 Mustangs 7 09-07-2015 08:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 06:31 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.