Speedometer Malfunctioning - MustangForums.com



V6 General Discussion This section is for non-tech specific information pertaining to V6 Mustangs.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-20-2017, 07:50 AM   #1
Crimson89
Thread Starter
 
Join Date: Feb 2017
Location: Maryland
Posts: 1
Default Speedometer Malfunctioning

I've been lurking on this site for a while as I attempt to fix up my car, but I haven't been able to really find any assistance with an issue that I have had with my car for quite some time. I'm attempting to change states and it fails inspection because of the broken speedometer.

The issue: speedo rests at max speed while idling and driving until about 3rd or 4th gear where it jumps up to 80mph and very slowly goes backward toward 75 as I gain speed (not at the same rate). I've changed the speed sensor located on the transmission housing under the car, but all that did was give the speedometer a little more pep as it shoots to 80mph from max and a little more sensitive to the pedal.

Any suggestions? Thanks a lot.
Crimson89 is offline   Reply With Quote
 
 
Reply


Tags
speed sensor, speedometer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:35 PM.