Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs
Sign in using an external account
Register Forgot Password?
Search


2005 - 2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Everyone please VOTE!!!! All mustang owners HERE!

Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-07-2007, 04:36 AM   #1
Juntech
3rd Gear Member
 
Juntech's Avatar
 
Join Date: Jan 2006
Location: Boston
Posts: 571
Send a message via AIM to Juntech Send a message via Yahoo to Juntech
Default Everyone please VOTE!!!! All mustang owners HERE!

Please VOTE!

Ok guys, i want to gauge the average # of problems in the S197. But i need alotta votes. Please contribute at least that. I've been seeing a lot of the same problems on all sorts of mustang boards. (Sqeeks, rattles, fuel system, electrical and the LEAK) I'm wondering if it's just the tiiiny percentage of actual owners posting or is it just about everyone.

If you want to add your year, engine and whatever else is related, feel free.

Thanks so much in advance. This poll will weigh heavily on whether or not i stroll into the dealerships and actually order within the next few weeks!!! (Thanks for putting up with my constant badgering and questions )
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
2012 Boss 302. Competition OJ
Juntech is offline   Reply With Quote
Old 01-07-2007, 04:47 AM   #2
Skoshi42
2nd Gear Member
 
Join Date: Jun 2006
Location: Kauai, Hawaii
Posts: 317
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Im tired of bringing it back into the dealer for false OBDII codes, so now all I do is reset my ECU by disconnecting my battery for 5 minutes and then reconnecting it... this is what my dealership does and not tell me, they say they fixed it and send me back home..

Edit:: I have no leak anywhere, i checked... dry as a bone.. so its just doing it on its own, pulling "ghost"codes..
__________________

" Your supposed to eat rice, not wear it!! " -skoshi
Skoshi42 is offline   Reply With Quote
Old 01-07-2007, 05:36 AM   #3
FordDude
2nd Gear Member
 
FordDude's Avatar
 
Join Date: Oct 2006
Vehicle: 2007 Ford Mustang
Location: Riverside, CA
Posts: 217
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

But I only have 891 miles on my Mustang, and I have only had it less than 2 months. fd
__________________

2007 GT Premium Redfire
5 Speed Manual
3.55 L/S
Spoiler delete
18" Polished 275/45 ZR18
FRPP Stingers
FordDude is offline   Reply With Quote
Old 01-07-2007, 05:47 AM   #4
shockme76
2nd Gear Member
 
Join Date: Apr 2006
Vehicle: 2006 Ford Mustang GT
Location: KY
Posts: 295
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Problems i've had....

Had the fuel sender replaced. (i think that's what it's called) Anyway, it was the problem where i had about a quarter of a tank of gas left and the fuel guage would go to E and then come back up shortly after. Took it to the dealer and it was a known TSB. They fixed it and i've had to problems from that since.

Last week i had a very weird problem. I was getting off from work and got to my car and tried to unlock it with the key fob. It didn't work so i thought the battery in it was dead. So i unlocked it with the key, got in, and started it up. Next thing i know it beeps, all the guages go down, and it starts telling me fuel level low, oil pressure low, etc. It says to check the charging system. My head lights, internal lights, and radio were all flickering off and on. But the car was running and running fine. Luckily i don't live to far from work and was able to get home ok. Since i couldn't unlock it with the key fob it had to be something before i started it up. I don't know if it could've been moisture that got on something or what. It only did it that night and hasn't done it since.

Those are the only two problems i've had. The first one is fixed and hopefully the second one doesn't happen again. If it does i'll be back to the dealership.
__________________
'06 GT
Vista Blue
Premium Package
C&L CAI
Diablosport Predator 93 Octane Tune
Corsa Axle-backs
shockme76 is offline   Reply With Quote
Old 01-07-2007, 06:18 AM   #5
howarmat
s197 Junkie
 
howarmat's Avatar
 
Join Date: Sep 2006
Vehicle: 2005 Mustang GT
Location: next to Nancy :)
Posts: 15,867
howarmat howarmat howarmat howarmat
Send a message via AIM to howarmat
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

E-brake is the only thing I had a problem with. Dealership fixed it and no problems since.
__________________
~Matt

"Shadow" 2005 Black GT Stick 1 of 368
its not stock


Every new day is the beginning of the rest of our lives together
howarmat is offline   Reply With Quote
Old 01-07-2007, 06:23 AM   #6
LegallyTorchRED
3rd Gear Member
 
Join Date: Sep 2006
Location:
Posts: 967
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Go order one. Aren't ya tired of countin' ?????[sm=boosign.gif][sm=violin.gif][sm=closed.gif]
LegallyTorchRED is offline   Reply With Quote
Old 01-07-2007, 11:13 AM   #7
saltzy
2nd Gear Member
 
Join Date: Sep 2006
Location: Massachusetts
Posts: 174
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Lame. Get a subscription to Consumer Reports, they've done this work for you already.
__________________
'06 GT 'vert - Torch Red, Premium & Red ICA
C&L CAI Brenspeed tune
Corsa Exhaust
CDC Classic chin
saltzy is offline   Reply With Quote
Old 01-07-2007, 11:40 AM   #8
Heavyg72
3rd Gear Member
 
Join Date: May 2006
Vehicle: 2003 Cobra Convertible
Location: Maryland
Posts: 774
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

I've only had 2 TSB issues (grinding noise around slow corners and fuel pick-up issues after long runs) and the dealership fixed them with no questions asked....despite my mods. Other than that it has been great.

__________________
03 Cobra Convertible in DSG
2.9" Pulley
Woodbine Motorsports Tune
UPR Catted X w/Flowmaster Catback
3.73 gears
Heavyg72 is offline   Reply With Quote
Old 01-07-2007, 11:43 AM   #9
my77stang
6th Gear Member
 
my77stang's Avatar
 
Join Date: Dec 2006
Vehicle: 77 II, 06 GT
Location: Citrus County, FL
Posts: 8,007
Send a message via AIM to my77stang Send a message via MSN to my77stang Send a message via Yahoo to my77stang
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

door mirrors rattle, seat lifter upper handle broke off in my hand, door panel pieces rattle (easy fix), and clutch pack in the rearend. also there have been several times it JUST WONT START and then after a few trys it does. dealer said they cant do anything because it didnt throw a code. theres 15,000 miles on ours right now, but all of these problems started at or around 5k
__________________
“‎Some of my finest hours have been spent on my back veranda, smoking hemp and observing as far as my eye can see.” - Thomas Jefferson
my77stang is offline   Reply With Quote
Old 01-07-2007, 02:52 PM   #10
Juntech
3rd Gear Member
 
Juntech's Avatar
 
Join Date: Jan 2006
Location: Boston
Posts: 571
Send a message via AIM to Juntech Send a message via Yahoo to Juntech
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Thanks for the vote guys, i will be picking up a Consumer Reports too. ANd it's always good to get real data from actual owners.
__________________
2012 Boss 302. Competition OJ
Juntech is offline   Reply With Quote
Old 01-07-2007, 03:06 PM   #11
RUFDRAFT
3rd Gear Member
 
Join Date: Nov 2006
Location: Washington NC
Posts: 577
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

3500 miles. No issues. It does, however, seem to be getting faster....
__________________
Vortech V2 - Polished - Eibach Sports/4.10's/headers - Bassani Off-Road X - Spydershaft - Hurst shifter - 18" Kazeras/BFGKDW/ sequential signals /Comp cams/Nitto 555R's/Diablo Tune/CDC spoiler/flush louvers/475 rwhp
RUFDRAFT is offline   Reply With Quote
Old 01-07-2007, 03:14 PM   #12
cheftjpeck
5th Gear Member
 
Join Date: Jul 2006
Location:
Posts: 3,834
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Quote:
ORIGINAL: RUFDRAFT

3500 miles. No issues. It does, however, seem to be getting faster....
or your foot is getting heavier....LOL
__________________
2008 SHELBY GT500 built 4/21/2008 #6097 / 6513 COUPES: #807 / 869 in VISTA BLUE
VISTA BLUE WITH WHITE STRIPES
FRPP CAI FRPP KR Axlebacks , LP Xpipe w High flow cats
VMP TVS
FRPP Lowering Springs, J&M Adj UCA, J&M LCA's,SVT Handling Package
676rwhp / 667 torque
cheftjpeck is offline   Reply With Quote
Old 01-07-2007, 03:17 PM   #13
cheftjpeck
5th Gear Member
 
Join Date: Jul 2006
Location:
Posts: 3,834
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

had window tint scratching (Fixed by dealer ) felt installed and window tint replaced by dealer
fuel PO8063 code.(or PO4063 code something like that...i forget)...had fuel sender replaced
has some squeaks and rattles in right front.....have not take it in for it YET....
other than that I love my stang
__________________
2008 SHELBY GT500 built 4/21/2008 #6097 / 6513 COUPES: #807 / 869 in VISTA BLUE
VISTA BLUE WITH WHITE STRIPES
FRPP CAI FRPP KR Axlebacks , LP Xpipe w High flow cats
VMP TVS
FRPP Lowering Springs, J&M Adj UCA, J&M LCA's,SVT Handling Package
676rwhp / 667 torque
cheftjpeck is offline   Reply With Quote
Old 01-07-2007, 04:14 PM   #14
ANBAUTO
4th Gear Member
 
Join Date: Jun 2006
Location:
Posts: 1,199
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

When i first got mine i had the air bag light come on the day of picking it up. The sales manager got it to turn off some how then 2 days later it came on and would come on all the time. They finally had it for the week at the dealership and they had to replace the seats. Its all better now the only thing now is that it makes all kinds of squeaks but i just turn up the radio
__________________
ANBAUTO is offline   Reply With Quote
Old 01-07-2007, 04:32 PM   #15
BHRS
1st Gear Member
 
Join Date: Sep 2006
Location:
Posts: 119
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

I have not had any problems with the car so far. I have a little over 2000 miles on it and I am more happy with it now than when I picked her up. The only changes I have made was the installation of a single Magnaflow muffler and disconnecting/reconnecting the battery to reset the computer.

Luckily my car stays under cover at home and work so I have not seen any leak problems. I have washed her several times and made a point to put more water in the pass side windsheld area to see if it leaks-so far NO LEAKS.
__________________
I am not originally from Texas or a Ford owner, but I got here as fast as I could!!!

'07 Premium Coupe
4.0 V6 Auto
Pony Package
Vista Blue/Light Graphite Cloth
Magnaflow Axle Back-SOUNDS GOOD!!!
BHRS is offline   Reply With Quote
Old 01-07-2007, 04:51 PM   #16
Fourth Horseman
2nd Gear Member
 
Join Date: Oct 2005
Vehicle: 2007 Mustang GT
Location: On your six, 1.2nm... and I have tone!
Posts: 455
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Only a little over 1000 miles on mine but so far so good. All of the little issues I might have run into (tint scratching, and freezing parking brake lines for example) I was able to avoid thanks to reading this forum. I have to say that my Mustang seems to be put together better with less little annoying issues than my 2003 Mercury was. Maybe quality is improving at Ford? Hope so. In any event, absolutely no complaints from me in my first 1000 miles on the GT.
__________________
Fourth Horseman is offline   Reply With Quote
Old 01-07-2007, 04:59 PM   #17
s2k
5th Gear Member
 
Join Date: May 2006
Location:
Posts: 2,272
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Around the 900ish miles my E-brake light stayed on and also my T/C would notturn on but the dealer fixed it it was due to a "poor connection" but it was a quick fix and no problems since!
__________________
s2k is offline   Reply With Quote
Old 01-07-2007, 05:02 PM   #18
Rupp
3rd Gear Member
 
Join Date: Aug 2006
Location: Huntsville, Al
Posts: 979
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

Quote:
ORIGINAL: Skoshi42

Im tired of bringing it back into the dealer for false OBDII codes, so now all I do is reset my ECU by disconnecting my battery for 5 minutes and then reconnecting it... this is what my dealership does and not tell me, they say they fixed it and send me back home..

Edit:: I have no leak anywhere, i checked... dry as a bone.. so its just doing it on its own, pulling "ghost"codes.. example video of it acting up with no problem what so ever...

http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=1 49397960
Have you moded your engine?
__________________
-Rupp
Rupp is offline   Reply With Quote
Old 01-07-2007, 05:25 PM   #19
Riggs007
2nd Gear Member
 
Join Date: Aug 2006
Location: Lloydminster, SK
Posts: 230
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

fuel sender, thats it
__________________

05 GT/5pd-FR Headers,Flow master,Diablo tune, 4.10
AR Rogues, Falkin wrapped
06-F350
97-GMC 4x4-572ci-505rwhp
05-Chev-Weatherford White
05-Mastiff/Rottie cross
Riggs007 is offline   Reply With Quote
Old 01-07-2007, 06:02 PM   #20
Drivesthebeast
2nd Gear Member
 
Join Date: Dec 2006
Location:
Posts: 157
Default RE: Everyone please VOTE!!!! All mustang owners HERE!

The parking brake freezing problem, yet to be remedied...that was after a week of buying the car used from the local Ford Store.

Then, when I was on my christmas leave, I was going to go somewhere with my dad to help out with a friends car, and had started the car to warm it up, and go to the house to lock up. Come back out to get in the car, and the driver side door is locked. The passenger side is locked, and of course, the trunk is locked. This is all while the engine was running, and the stereo was going. I had to get a locksmith to come and unlock the car for me (which took him 90 mins!). I wasn't happy, as I was locked out of the car with it running, so as an "etiquette lesson", I switched off the TCS as soon as I got in the car, pulled out of the driveway, and scat the car almost sideways through 2 gears up the street, shifting at over 5000rpm. Had 2 cop cars roll down the street past my parents house about 15-20 mins later after I had returned and parked...

I also have some rattles from the passenger side of the car, I think it has to do with the window.

No leaks, no fuel delivery issues, no ignition issues.
__________________
I used to drive with "Focus" now I steer with the rear
Drivesthebeast is offline   Reply With Quote
Old 01-07-2007, 06:02 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
03, 2005, 2007, 427r, boston, build, car, cobra, early, fast, issues, mustang, owners, roush, sale

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 06:18 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup