So I broke something... - Page 3 - MustangForums.com


Go Back   MustangForums.com > Ford Mustang Tech > 2005-2014 Mustangs
Search


2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by XForce USA


So I broke something...

Reply
 
 
 
Thread Tools Search this Thread
Old 04-29-2013, 07:35 PM   #21
Andy13186
4th Gear Member
 
Andy13186's Avatar
 
Join Date: Apr 2008
Posts: 1,781
Default

what the hell.. what kind of steeda springs? i have steeda sports atm.. Im guessing you had ultralites?
__________________
2011 GT Premium Manual with : Steeda 101mm CAI, Forgestar F14's, Bridgestones s004 and s007 tires, Steeda sport springs, Koni sport dampers, Maximum Motorsports caster camber plates, J&M extreme joint LCA's, On-car adjustable panhard bar, Strano front sway bar, stock mufflers, remote electric cutouts, Bama 93r tune.
Andy13186 is offline   Reply With Quote
Old 04-29-2013, 07:49 PM   #22
legendlime05
4th Gear Member
 
legendlime05's Avatar
 
Join Date: May 2007
Vehicle: 2005 ford mustang
Location: iowa
Posts: 1,617
Default

who installed the springs?
could something have gone wrong with the install to make them defective?
__________________
legendlime05 is offline   Reply With Quote
Old 04-29-2013, 07:59 PM   #23
DocSnickers
3rd Gear Member
 
DocSnickers's Avatar
 
Join Date: Nov 2012
Vehicle: 2013 GTHG Ford Mustang
Location: WA
Posts: 863
Default

Maybe a gorilla jumped on the fender at this college hooligan event?
DocSnickers is offline   Reply With Quote
Old 04-29-2013, 08:36 PM   #24
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Vehicle: 2013 MCA convertible
Location: Michigan
Posts: 6,211
Default

Thread cleaned - if you have nothing useful to add to the conversation then "remember what your Mom told you"
__________________

JimC is offline   Reply With Quote
Old 04-29-2013, 11:46 PM   #25
4LiterSonic
2nd Gear Member
 
4LiterSonic's Avatar
 
Join Date: Apr 2010
Vehicle: 2005 Sonic Blue V6
Location: Tennessee
Posts: 447
Remember Reach
Default

Quote:
Originally Posted by Andy13186 View Post
what the hell.. what kind of steeda springs? i have steeda sports atm.. Im guessing you had ultralites?
I've got sports. Might want to check for hairline cracks if you get a chance.
Quote:
Originally Posted by legendlime05 View Post
who installed the springs?
could something have gone wrong with the install to make them defective?
I have no idea. I've put almost 40k on the car since I've been driving it and I've never had any hint of a problem from my front left.

Quote:
Originally Posted by DocSnickers View Post
Maybe a gorilla jumped on the fender at this college hooligan event?
Haha, it's possible. I do have letters on the back but I think we can rule out sabotage. I doubt anyone would go through this much trouble when a key would suffice.

I made a new thread to cover the spring issue. Pictures here:

http://mustangforums.com/forum/2005-...rt-spring.html
__________________
Sonic Blue '05 4.0...too many mods to list
Quote:
Originally Posted by Fifthwind View Post
It's like building a howitzer that also shoots BBs just so you can use it around the house.

Last edited by 4LiterSonic; 04-29-2013 at 11:49 PM.
4LiterSonic is offline   Reply With Quote
Old 04-30-2013, 11:17 AM   #26
2005Redfire6
6th Gear Member
 
Join Date: Jul 2008
Vehicle: 2005 Mustang
Location: Acworth, GA
Posts: 12,258
Default

Quote:
Originally Posted by JimC View Post
Thread cleaned - if you have nothing useful to add to the conversation then "remember what your Mom told you"
Dammit Jim, you deleted my picture! Lol.


EDIT: Dang man that thing snapped clean!
__________________
Eddie
Livernois 298 stroker

Last edited by 2005Redfire6; 04-30-2013 at 11:20 AM.
2005Redfire6 is offline   Reply With Quote

 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shift Linkage Broke, Could Really Use Some Help CMcNam 4.6L V8 Technical Discussions 15 12-06-2015 01:28 PM
1996 GT Studdering problems.. Need Help stangin1996gt 4.6L (1996-2004 Modular) Mustang 0 09-21-2015 11:01 AM
HELP A/C Wont blow cold, electrical 2008 cbird1177711 2005-2014 Mustangs 0 09-02-2015 04:12 PM
fix my problem steelers743 New Member Area 3 08-31-2015 07:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 

All times are GMT -5. The time now is 11:31 PM.



This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company