Go Back   MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Sign in using an external account
Register Forgot Password?
Search


4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.
Sponsored by Cruizin Concepts


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-26-2009, 07:56 PM   #1
UmX
3rd Gear Member
 
UmX's Avatar
 
Join Date: Apr 2006
Vehicle: 2006 C6 Corvette
Location: Canton, Mi
Posts: 740
Send a message via AIM to UmX Send a message via Yahoo to UmX
Default Front Raditor or w.e brace lol

Was wondering if this can be fixed or replaced..

The guy who owned the car before im guessing lifted the car from here..

Anyways suggestions,,,



This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
2006 C6 Modded/2014 Titanium Fusion - modded
UmX is offline   Reply With Quote
Old 10-26-2009, 08:03 PM   #2
Sxynerd
6th Gear Member
 
Sxynerd's Avatar
 
Join Date: Feb 2006
Vehicle: 96 GT Vert 600rw (Gone)
Location: Virginia
Posts: 11,748
Default

I pulled my radiator and stepped on mine. Worked fine. :0)
__________________
Sxynerd is offline   Reply With Quote
Old 10-26-2009, 08:40 PM   #3
UmX
3rd Gear Member
 
UmX's Avatar
 
Join Date: Apr 2006
Vehicle: 2006 C6 Corvette
Location: Canton, Mi
Posts: 740
Send a message via AIM to UmX Send a message via Yahoo to UmX
Default

Quote:
Originally Posted by sxynerd View Post
I pulled my radiator and stepped on mine. Worked fine. :0)
nice.. ya mine is pretty effed up.. lol mean granded u dont really see it. but i know its there ya kno?
__________________
2006 C6 Modded/2014 Titanium Fusion - modded
UmX is offline   Reply With Quote
Old 10-27-2009, 06:24 AM   #4
4.698GT
4th Gear Member
 
Join Date: Jan 2005
Vehicle: 1998 Mustang GT
Location: Port Monmouth, New Jersey
Posts: 1,982
Default

thats part of the lower core support. probably a piece that would have to be unbolted/welded and reinstalled. I would try massaging it back into place with a hammer next time the rad is out.

Actually I noticed there are some holes in it. Maybe try a slide hammer
__________________
1998 Mustang GT- Cammed PI Motor and bolt ons 292 whp 306 Trq, tubular front suspension, Built Rear
2010 Dodge Avenger R/T- Brilliant Black- Stock
4.698GT is offline   Reply With Quote
Old 10-27-2009, 06:24 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 01:33 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup