charging system issues - Page 2 - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-29-2008, 08:49 PM   #11
1992lx5.0
1st Gear Member
 
Join Date: Mar 2006
Location:
Posts: 94
Default RE: charging system issues

http://www.corral.net/tech/maintenance/130a-tech.htmlthats to help you under stand the 3g, if a fusabel link is blown no moving it around will get it to work, but i wouldnt think that is really the prob.. i would buy a new alt for sure and make sure everything is in proper working order first then after that its process of elimination
1992lx5.0 is offline   Reply With Quote
Old 03-29-2008, 08:56 PM   #12
projectresto83
M.A.D. Motorsports
 
projectresto83's Avatar
 
Join Date: Jul 2006
Location: Indiana
Posts: 7,999
Default RE: charging system issues

Something that wasn't mentioned unless I missed it. When you do check the charging what does the mutimeter say when you are checking it with the car running?????
projectresto83 is offline   Reply With Quote
Old 03-29-2008, 09:06 PM   #13
Dale 5.0
Thread Starter
 
Join Date: Sep 2007
Posts: 15
Default RE: charging system issues

About 12.06 volts is the average. And that's after I charged the battery for a few hours.
Dale 5.0 is offline   Reply With Quote
Old 03-29-2008, 09:17 PM   #14
projectresto83
M.A.D. Motorsports
 
projectresto83's Avatar
 
Join Date: Jul 2006
Location: Indiana
Posts: 7,999
Default RE: charging system issues

Ok, just making sure.
projectresto83 is offline   Reply With Quote
Old 03-30-2008, 12:25 AM   #15
1992lx5.0
1st Gear Member
 
Join Date: Mar 2006
Location:
Posts: 94
Default RE: charging system issues

shouldnt the volt meter say some where around 13 - 14ish to be charging correctly mine charges at 13.45 consitantly at idle, granted i have a higher idle because of my cam but still to make up for the surge its ruffly 13.45
1992lx5.0 is offline   Reply With Quote
Old 03-30-2008, 09:31 AM   #16
projectresto83
M.A.D. Motorsports
 
projectresto83's Avatar
 
Join Date: Jul 2006
Location: Indiana
Posts: 7,999
Default RE: charging system issues

Yup. Sound like you are charging well.
projectresto83 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Power Adder Sale Granatelli Sales Vendor For Sale / Group Buy Classifieds 9 03-21-2016 07:16 PM
01 Mustang Overheating :( MusicCity615 General Tech 7 09-12-2015 08:05 AM
Steeda's S550 Mustang GT Axle-Back Exhaust System - Video Inside tj@steeda Steeda Autosports 0 09-10-2015 09:39 PM
Ford EPEC system uedlose Parts For Sale 0 09-10-2015 04:30 PM
Steeda & Nitto Tire Testing NT555 G2 - Great Photos Inside!! tj@steeda Steeda Autosports 0 09-08-2015 12:50 PM


Tags
1995, 3g, 50, alternator, charging, dies, ford, mustang, not, system

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 04:41 PM.