Backup camera issues? - MustangForums.com



The New S550 2015-2017 Mustang Discussions on the newest generation of the Ford Mustang.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 03-18-2017, 09:40 AM   #1
Loue
Thread Starter
 
Join Date: Mar 2017
Location: Arizona
Posts: 10
Default Backup camera issues?

Anyone else experiencing issues with their backup camera on their 15-17 mustang? After having mine for a year just last week when I was backing out of my driveway it started to flicker and shut off. Just this morning it just wouldn't show and a message popped up saying backup camera not available. Is there anyway I can fix it or should I take it to the dealership?
Loue is offline   Reply With Quote
Old 03-18-2017, 10:25 AM   #2
09Busaman
 
09Busaman's Avatar
 
Join Date: Mar 2017
Location: California
Posts: 7
Default

Mine is 2 years old and working well. Is yours under warranty? Take it back to the dealer if so, should be covered.
09Busaman is offline   Reply With Quote
Old 03-21-2017, 10:20 AM   #3
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,317
Default

If it's under warranty don't touch it.

No problems with mine. Needs a good cleaning once in a while.
movielover40 is offline   Reply With Quote
Old 03-22-2017, 08:51 AM   #4
Loue
Thread Starter
 
Join Date: Mar 2017
Location: Arizona
Posts: 10
Default

Took it to the dealership warranty covered it, works perfectly
Loue is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 12:42 AM.