Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Need help

Old 03-21-2012, 05:21 PM
  #1  
Brian1968
Thread Starter
 
Join Date: Mar 2012
Location: canada
Posts: 5
Default Need help

Ok so I take my 05 out for the first time today I turn left and my turn signal is blinking fast.So I think burnt out bulb but after checking the bulbs are fine.I look at fuses don't see any that are broken. From what I can see it looks like this one bulb is fine nice and bright the next is a little duller and the last is very dull.If I just have the DRL on it looks fine. I don't know what else to look for.
Brian1968 is offline  
Old 03-21-2012, 05:23 PM
  #2  
ironh19
3rd Gear Member
 
ironh19's Avatar
 
Join Date: Jan 2005
Location: Florida
Posts: 622
Default

check the blinker fluid you might be low. or replace start replacing bulbs because one of them maybe about to go out. and its causing a draw somewhere.
ironh19 is offline  
Old 03-21-2012, 06:28 PM
  #3  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

If the bulbs are good, the next thing I'd do is clean the socket contacts AND the contacts on the wiring harness plug.
Nuke is offline  
Old 03-22-2012, 07:11 AM
  #4  
wcgman
5th Gear Member
 
wcgman's Avatar
 
Join Date: Mar 2006
Location: Colorado
Posts: 2,652
Default

[QUOTE=ironh19;7883229]check the blinker fluid you might be low. QUOTE]

I think Pep Boys has a special on gallon size blinker fluid this week too.
wcgman is offline  
Old 03-22-2012, 02:13 PM
  #5  
ironh19
3rd Gear Member
 
ironh19's Avatar
 
Join Date: Jan 2005
Location: Florida
Posts: 622
Default

[QUOTE=wcgman;7883975]
Originally Posted by ironh19 View Post
check the blinker fluid you might be low. QUOTE]

I think Pep Boys has a special on gallon size blinker fluid this week too.
damn and the nearest one by me is all the way in pensacola.
ironh19 is offline  
Old 03-22-2012, 02:22 PM
  #6  
kevinmalec
5th Gear Member
 
kevinmalec's Avatar
 
Join Date: Apr 2008
Location: Acworth, GA
Posts: 3,666
Default

That's odd....you check all 6 bulbs on the rear and the 2 front turn signals?
I had the same issue, however it was the turn signal bulb that burnt out in the tail light.
kevinmalec is offline  
Old 03-22-2012, 03:31 PM
  #7  
AzPete
4th Gear Member
 
AzPete's Avatar
 
Join Date: Aug 2008
Location: Panama City, FL
Posts: 1,214
Default

Did you actually check the bulbs when they were flashing as a turn signal? Compare left to right.... Have seen many that thought because the tail lights work, the bulbs are fine......or change the fluid as suggested.
AzPete is offline  
Old 03-22-2012, 06:03 PM
  #8  
Brian1968
Thread Starter
 
Join Date: Mar 2012
Location: canada
Posts: 5
Default

Got it.. the front bulb keeps falling out fixed the socket contacts now it good and tight.Now i have to figure out why my ABS light is staying on??? OH and yes the fluid is nice and full..thanks
Brian1968 is offline  
Old 03-22-2012, 09:42 PM
  #9  
ironh19
3rd Gear Member
 
ironh19's Avatar
 
Join Date: Jan 2005
Location: Florida
Posts: 622
Default

faulty abs sensor, have you been inside your wheels lately? doing brake jobs and such?
ironh19 is offline  
Old 03-23-2012, 02:35 PM
  #10  
Brian1968
Thread Starter
 
Join Date: Mar 2012
Location: canada
Posts: 5
Default

did new rotors and pads at the end of last fall.
Brian1968 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.