CLUSTER GAUGES DIM!!!! - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 2005-2014 Mustangs
Reload this Page >

CLUSTER GAUGES DIM!!!!

Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

CLUSTER GAUGES DIM!!!!

Old 03-16-2019, 01:02 PM
  #1  
pauls06
Thread Starter
 
pauls06's Avatar
 
Join Date: Mar 2019
Location: FL
Posts: 2
Default CLUSTER GAUGES DIM!!!!

I have a 06 Roush that the instrument cluster gauges are dim but but radio time display and all other non Roush dash lights work perfectly and work as should when you use dial to dim and brighten. The white backing on Roush gauges seem like they donít light at all! The red u see in photos do dim and brighten. See photo of them at full strength. Fuses are fine, was thinking headlight rheostat but lights do dim and brighten turning ****. Anyone else have this problem.
pauls06 is offline  
Old 03-16-2019, 01:20 PM
  #2  
pauls06
Thread Starter
 
pauls06's Avatar
 
Join Date: Mar 2019
Location: FL
Posts: 2
Default

Here is photo!!!

Photo of dash
pauls06 is offline  
Old 03-16-2019, 02:25 PM
  #3  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,298
Default

Unless somehow the Forum operation and access is causing your problem ..................
Forum Issues and Feedback Discuss any issues you are having with using Mustang Forums here.
You are in the wrong section. You need to post questions about your Mustang in the proper section. There is section just for the S197 (2005-14) Mustang. Someone with mod powers in this section will have to move your post to the correct section.

Welcome new member, please take time to learn how the forum structure is set up
JimC is offline  
Old 03-19-2019, 06:58 AM
  #4  
99GTvert
is my username.
 
99GTvert's Avatar
 
Join Date: May 2006
Location: Earth
Posts: 13,743
Default

Moved to tech.

99GTvert is offline  
Old Yesterday, 08:43 PM
  #5  
danzcool
4th Gear Member
 
danzcool's Avatar
 
Join Date: Oct 2008
Location: CA
Posts: 1,955
Default

I think something on the gauge cluster itself is bad since the needles do light, and that comes through the same cable assembly. You could pull and test the gauge cluster to find out is a single LED is blown or if a circuit trace fried, but it may be a better option to pick up a used GT cluster off ebay with a similar mileage (or pay them extra to program the mileage accurately). When you get that you will need to pull the needles and remove the cluster applique sticker and put the Roush applique sticker on the replacement. I would tend to put it in without the applique sticker first just to make sure it is in working order then replace the needles and applique.

You could send it to Roush for service/replacement, but I'm guessing that would not be covered under warranty anymore.
danzcool is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
msavoia23
V6 (1994-2004) Mustangs
1
07-04-2014 02:37 PM
Norsky
4.0L V6 Technical Discussions
11
12-15-2012 10:28 AM
nativenyerintexas
V6 (1994-2004) Mustangs
13
08-14-2012 06:20 AM
1999 GT
4.6L (1996-2004 Modular) Mustang
3
01-24-2009 11:13 AM
snidehockey
4.6L (1996-2004 Modular) Mustang
1
10-13-2007 12:40 AM


Thread Tools
Search this Thread
Quick Reply: CLUSTER GAUGES DIM!!!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.