Notices
2010-current S197 Appearance Section For all appearance mods to the 2010-2014 S197's

Swapping out fog lights for LED's?

Old 05-17-2012, 11:34 PM
  #1  
CAMS5762
Thread Starter
 
Join Date: Apr 2012
Location: Virginia
Posts: 23
Default Swapping out fog lights for LED's?

I am thinking about swapping out my factory fog lights (H10 or 9145 bulb size) to an LED setup. I'm concerned about the amount of light it will produce though. I hear that LED's just aren't as bright, anybody have experience? I'm ok with having a LITTLE dimmer than stock, I would just also prefer the fogs to have at least a little functionality.
CAMS5762 is offline  
Old 05-18-2012, 12:29 AM
  #2  
russellthelovemuscle
2nd Gear Member
 
russellthelovemuscle's Avatar
 
Join Date: Apr 2012
Location: CA
Posts: 173
Default

i would say go for it. i personally think led's make the stang look much crispt and cleaner
russellthelovemuscle is offline  
Old 05-18-2012, 01:33 PM
  #3  
BKamp613
2nd Gear Member
 
Join Date: Jun 2011
Location: MD
Posts: 471
Default

I did it. They're plenty bright, but the output isn't as much as halogen (in terms of "shine distance"). I like the way they looked though. 7.5watts. DiodeDynamics.



BKamp613 is offline  
Old 05-18-2012, 02:45 PM
  #4  
majik755
2nd Gear Member
 
majik755's Avatar
 
Join Date: Apr 2010
Location: Virginia
Posts: 332
Default

Same experience here, they look bright and white, but definitely don't throw the light as far forward.
majik755 is offline  
Old 05-18-2012, 03:58 PM
  #5  
bigD1515
3rd Gear Member
 
bigD1515's Avatar
 
Join Date: Feb 2012
Location: GA
Posts: 578
Default

Originally Posted by BKamp613 View Post
I did it. They're plenty bright, but the output isn't as much as halogen (in terms of "shine distance"). I like the way they looked though. 7.5watts. DiodeDynamics.
hmm didn't know you had LED's in there. When I get fogs I'll definitely do that then.

OP, seems like its possible and looks really good. DO IT! And then show us
bigD1515 is offline  
Old 05-18-2012, 11:30 PM
  #6  
CAMS5762
Thread Starter
 
Join Date: Apr 2012
Location: Virginia
Posts: 23
Default

Just ordered the LED fogs. I'll try to figure out how to put up some pictures when I get them in. NOW for a second question. This is more of WHERE THE HECK DO I FIND IT?!!? I'm looking for a "y" harness so i can hook up both the stock grille fogs AND the fogs in the boss 302 fascia simultaneously. I would be comfortable making my own harness, I just need a place to purchase connectors. Anybody found a vendor with good prices and service?
CAMS5762 is offline  
Old 05-23-2012, 11:29 PM
  #7  
CAMS5762
Thread Starter
 
Join Date: Apr 2012
Location: Virginia
Posts: 23
Default

so the LED bulbs showed up today. I tried to install them but the connectors (standard H10 plugs) were REALLY tight, it was a real challenge getting them in and out. Also, when plugged in, the LED bulb would not light up (I checked proper function of the bulb with a meter) Any suggestions? Any thoughts on why the LED wont light up but the stock halogen will?
CAMS5762 is offline  
Old 05-24-2012, 04:47 AM
  #8  
Forty-two
1st Gear Member
 
Join Date: Apr 2012
Location: Austria/Europe
Posts: 54
Default

LEDs work only when plugged in the correct way. try turning it 180

maybe that's also the reason why it was so hard to put them in.
Forty-two is offline  
Old 05-26-2012, 09:33 PM
  #9  
CAMS5762
Thread Starter
 
Join Date: Apr 2012
Location: Virginia
Posts: 23
Default

Originally Posted by Forty-two View Post
LEDs work only when plugged in the correct way. try turning it 180

maybe that's also the reason why it was so hard to put them in.

appropriate answer. You were correct. I put power to the LED's going the opposite way and they light up. (stupid of me not to check that) I did however verify that I was plugging the bulbs in correctly to the socket, still extraordinarily tight.
CAMS5762 is offline  
Old 05-26-2012, 11:16 PM
  #10  
bigD1515
3rd Gear Member
 
bigD1515's Avatar
 
Join Date: Feb 2012
Location: GA
Posts: 578
Default

Originally Posted by CAMS5762 View Post
appropriate answer. You were correct. I put power to the LED's going the opposite way and they light up. (stupid of me not to check that) I did however verify that I was plugging the bulbs in correctly to the socket, still extraordinarily tight.
show pics
bigD1515 is offline  

Thread Tools
Search this Thread
Quick Reply: Swapping out fog lights for LED's?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.