Notices
4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Horn Problems???

Old 05-28-2007, 10:27 PM
  #1  
XPSII800HO
1st Gear Member
Thread Starter
 
Join Date: Mar 2007
Location:
Posts: 51
Default Horn Problems???

I have an '02 GT, today the horn seem to stop working. When I lock with the remote, it was kinda making a squaking sound, then stopped all together for a bit. Now it is back to just making the squeaking sound. Think it would be a bad ground? Or do I just need a new horn?
XPSII800HO is offline  
Old 05-28-2007, 10:30 PM
  #2  
CobraStangGT16
5th Gear Member
 
Join Date: Aug 2006
Location: Orange County, CA
Posts: 2,584
Default RE: Horn Problems???

Fuse? Maybe a bad ground. Or maybe it got wet. Thats my guess.
CobraStangGT16 is offline  
Old 05-28-2007, 10:33 PM
  #3  
8banger
4th Gear Member
 
8banger's Avatar
 
Join Date: Oct 2006
Location: Kentucky
Posts: 1,460
Default RE: Horn Problems???

Check for voltage at the horn itself,,make sure its grounded properly..and then if thats fine....get a new horn..
8banger is offline  
Old 05-28-2007, 10:37 PM
  #4  
XPSII800HO
1st Gear Member
Thread Starter
 
Join Date: Mar 2007
Location:
Posts: 51
Default RE: Horn Problems???

where is the horn located, I'm guessing behind the grill some where?
XPSII800HO is offline  
Old 05-28-2007, 10:40 PM
  #5  
rbstang
6th Gear Member
 
Join Date: Apr 2005
Location: Wilmington, NC
Posts: 5,608
Default RE: Horn Problems???

i with cobra prob fuse blew or bad ground... unless you using the horn daily i doubt it would be broken on an 02.... but you never know stuff breaks
rbstang is offline  
Old 05-29-2007, 12:05 AM
  #6  
99gtstang
5th Gear Member
 
99gtstang's Avatar
 
Join Date: Jul 2006
Location: GA
Posts: 3,015
Default RE: Horn Problems???

ORIGINAL: XPSII800HO

I have an '02 GT, today the horn seem to stop working. When I lock with the remote, it was kinda making a squaking sound, then stopped all together for a bit. Now it is back to just making the squeaking sound. Think it would be a bad ground? Or do I just need a new horn?
there are 2 of them facing each other... driver side in the behind the bumper. Basically in front of that tire.

lol i know becuase i put a Air horn on my car today ))))))))))))))) super loud
99gtstang is offline  
Old 05-29-2007, 05:52 PM
  #7  
markdr
 
Join Date: May 2007
Location:
Posts: 9
Default RE: Horn Problems???

I had the same trouble on my 2000. Took it to a Ford dealer who has been around a loooooong time and does work on mustangs including mods. Tech said he saw it a lot, for some reason the horns are apt to get water in them from a road splash or whatever. Mine never dried out so I had to get it replaced. I was driving around sounding like a 1986 toyota tercell for a little while before I got it fixed, it was driving me nuts!!!
markdr is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Seanam
V6 S197 General Discussion
5
10-04-2015 10:15 AM
mdj89
5.0L (1979-1995) Mustang
7
09-23-2015 08:49 AM
stangin1996gt
4.6L (1996-2004 Modular) Mustang
0
09-21-2015 11:01 AM
Big Al's 03
Mach 1 Section
4
09-21-2015 07:59 AM
Pyrate Dave
5.0L (1979-1995) Mustang
8
09-10-2015 07:30 PM


Thread Tools
Search this Thread
Quick Reply: Horn Problems???


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.