Slight surge at 1500ish rpm - MustangForums.com

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Slight surge at 1500ish rpm

Reply

 
 
 
Old 09-24-2015, 09:50 PM
  #1  
lmurf60
Thread Starter
 
Join Date: Sep 2015
Location: Illinois
Posts: 1
Default Slight surge at 1500ish rpm

I have a 1996 Mustang GT with 129,000 miles. I bought the car to teach myself how to work on cars and preserve a wonderful Mustang. When I bought it it missed under load, changed spark plugs, plug wires, and coils and fixed that. But the car also has a slight surge at 1500 rpms (+100 rpms or so). To address this I have so far changed IAC and PCV valve and hose. What else could it be? Thank you in advance for any input.
lmurf60 is offline  
Reply With Quote
Old 09-24-2015, 11:07 PM
  #2  
Urambo Tauro
3rd Gear Member
 
Urambo Tauro's Avatar
 
Join Date: Aug 2015
Location: SE Michigan
Posts: 811
Default

The next thing I'd do is clean the MAF and throttle body.

Also, I've heard that aftermarket "cold" air intakes can sometimes produce a similar problem...
Urambo Tauro is online now  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dokilar
4.6L (1996-2004 Modular) Mustang
15
10-16-2015 09:13 PM
Sixer4Life
V6 (1994-2004) Mustangs
5
10-12-2015 05:26 AM
UrS4
S197 Handling Section
10
10-03-2015 07:23 AM
CS2007
General Tech
7
09-29-2015 08:38 PM
MacSerio
5.0L (1979-1995) Mustang
3
09-27-2015 02:05 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory