What radiator are you using!!! - Page 2 - MustangForums.com


4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-12-2014, 07:21 PM   #11
RMK01GT
1st Gear Member
 
RMK01GT's Avatar
 
Join Date: Feb 2012
Location: Alberta
Posts: 61
Default

are you sure you need a new radiator? at idle, with the fans running it should more more than efficient enough to cool off ANY engine...

Check for other issues first;

- proper amount of coolant
- engine oil level
- is the thermostat opening when it reaches temp
- Is the rad cap in good condition
- are the fans running
- is there a blockage between cooler and condenser
- head gasket issues

you may know about all these things, but I decided to post this because no one else has commented on other problems that could cause overheating
RMK01GT is offline   Reply With Quote
Old 08-13-2014, 09:14 AM   #12
Bman2000
4th Gear Member
Thread Starter
 
Join Date: Apr 2009
Location: oregon
Posts: 1,501
Default

I thought stock thermostat was 180? In anycase I don't have a factory intake I have a eddy vic jr. And as far as what I have that much tied up into.
Teksid
1000s 5.0 mmr stroker 24cc dish arp 2000 hardware
Ap steel rings
Melling high pressure oil pump
Mhs Stage 3 head cam combo w manley beadlock ss valves stage 3 blower cams with hd springs
Victor jr with eddy fuel rails sheet metal upper intake.
10%od innovators west dampener
BBK lt with cat less x pipe.
Snow stage 3 water methanol injection
Mcleod original twin w/ aliminum flywheel
Custom made 26 spline input.
That was the stuff to make this set up work, then the tranny dropped 4th so now I have bronze shift pads the shift forks were already steel, carbon fiber blocker rings and billet keys.
And even though it wasn't in this years upgrade I also have a lethal performance budget return system running 2 aeromotive stealth 340s, and a vortech si trim with a 3.25 tungsten carbide coating and a tread stone 3 core Fmic tial 50mm bov and hpx slow style maf through 75mm accufab tb.

I also tried repainting the car but the clear had epic issues but just this year I have receipts for pretty close to is say about 14k. Not including paint stuff. And at this point the other stuff I need to fix like my melted steering shaft and burned o2 sensors...
Bman2000 is offline   Reply With Quote
Old 08-13-2014, 11:13 AM   #13
Bman2000
4th Gear Member
Thread Starter
 
Join Date: Apr 2009
Location: oregon
Posts: 1,501
Default

I honestly think the over heating was a fan issue. But it was hot as ***** out and when the ac stopped working I forgot to check the fans I was more curious as to why the ac stopped working. So once I fix the steering shaft and o2 sensors I'll be checking that stuff out because like you I don't see it over heating at idle. Even though humidity was high and it was 95 out lol
Bman2000 is offline   Reply With Quote
Old 08-13-2014, 11:33 AM   #14
kast1376
3rd Gear Member
 
kast1376's Avatar
 
Join Date: Jun 2006
Location: Sacramento
Posts: 672
Default

Stock Therm is 195 I believe. My new intake goes on tomorrow along with a 180 degree therm. It should make a little difference hopefully.
kast1376 is offline   Reply With Quote
Old 08-13-2014, 02:07 PM   #15
uberstang1
Chupacabra
 
uberstang1's Avatar
 
Join Date: Jul 2004
Location: wilkes-barre PA
Posts: 9,612
Default

I will say with my fluidyne, my electric fan has never kicked on yet.
uberstang1 is offline   Reply With Quote
Old 08-13-2014, 08:13 PM   #16
Bman2000
4th Gear Member
Thread Starter
 
Join Date: Apr 2009
Location: oregon
Posts: 1,501
Default

Do you street drive that beast?lol I mean I know it says street car just looks all mean and ****...what is your set up anyway?
Bman2000 is offline   Reply With Quote
Old 08-14-2014, 07:06 AM   #17
uberstang1
Chupacabra
 
uberstang1's Avatar
 
Join Date: Jul 2004
Location: wilkes-barre PA
Posts: 9,612
Default

Street drive it all the time including 60 miles to the track and back home?
. Drive it 120 miles to carlisle ever year as well. 04 cobra block with 04 crank and rods, mmr street mod pistons. B beads, custom grind blower cams goin in now manley nextek valve springs. D1sc on 20psi at 5900rpms 603rwhp before cams. Should be about 700 with cams and revvin to 7. Viper spec t56 with liberty 26 spline input. N2mb wot box, blown up rear atm but 31 spline mpsers 04 diff welded tubes 4.10s. Team z 4 ljnk setup tubular front end, caged, 28x12.50 et streets. Sure im missing sometging but witg stock heads and cams was floating springs at 5900rpms but at 590p ot makde 603/522 on 20 psi
uberstang1 is offline   Reply With Quote
Old 08-14-2014, 08:51 AM   #18
Bman2000
4th Gear Member
Thread Starter
 
Join Date: Apr 2009
Location: oregon
Posts: 1,501
Default

I was gonna say 5900 seems low for that kind of build but lack of cams and springs would explain it, I'd say you stand a good Chance at 700, how much you have left in the blower? Sounds like your current set up may be maxed at 7k. In any case I'm hoping for your current numbers but at 7k instead of 5900 through an si trim.
Bman2000 is offline   Reply With Quote
Old 08-14-2014, 09:38 AM   #19
uberstang1
Chupacabra
 
uberstang1's Avatar
 
Join Date: Jul 2004
Location: wilkes-barre PA
Posts: 9,612
Default

My d1sc is about pullied out, and I run a 10%od crank. Curious to see how much boost was missing from 5900 to 7k though, probably gonna add meth as well considering the boost to pump gas ratio as well.
uberstang1 is offline   Reply With Quote
Old 08-14-2014, 10:05 AM   #20
Bman2000
4th Gear Member
Thread Starter
 
Join Date: Apr 2009
Location: oregon
Posts: 1,501
Default

Is it pullied out at 5900? Or current set up will max sc out at 7? I've seen almost 700 out of a 2v on a d1sc but that doesn't flow near as well as b heads and it was on e-85. You def need meth, surprised you aren't running it already with 20psi. Your leaving a lot on the table I would think. My tuner wouldn't let me run 18 without meth lol. You just ed up pulling all the timing to make it work anyway almost seems pointless but it obviously worked in your case
Bman2000 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Mustang Expansion Tank Granatelli Sales The New S550 2015-2017 Mustang 21 04-27-2017 01:33 PM
1996 GT Studdering problems.. Need Help stangin1996gt 4.6L (1996-2004 Modular) Mustang 0 09-21-2015 11:01 AM
2002 V6 will not start Beerman309 V6 (1994-2004) Mustangs 2 09-19-2015 01:16 AM
01 Mustang Overheating :( MusicCity615 General Tech 7 09-12-2015 07:05 AM
HELP.. Should I buy this fox? raleigh05GTO New Member Area 5 09-04-2015 07:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 11:54 AM.