Check Engine Light?? - MustangForums.com



4.6L V8 Technical Discussions Any questions about engine, transmission, or gearing can be asked here!

Reply
 
 
 
Thread Tools Search this Thread
Old 08-19-2010, 10:57 PM   #1  
Jmoss
2nd Gear Member
Thread Starter
 
Jmoss's Avatar
 
Join Date: Aug 2006
Location: Chicago, IL
Posts: 331
Default Check Engine Light??

Hey everyone,

I just received my JLT intake and tuner combo from AM today. After I installed it all, I took her for a ride and my check engine light was on, so I changed tunes and it went away, then I went for another ride and the light is on again now. Any suggestions? ANy help would be appreciated!

Thanks!
Jmoss is offline   Reply With Quote
Old 08-20-2010, 05:21 AM   #2  
REDBOSS1
3rd Gear Member
 
Join Date: May 2009
Location: Illinois
Posts: 879
Default

Make sure you put their tune in on custom tune, I did it wrong the first time I used one of these. I'm sure if you call them they can walk your through some trouble shooting.
REDBOSS1 is offline   Reply With Quote
Old 08-20-2010, 07:02 AM   #3  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Occasionally, there can be an air leak after the initial install. Go over all the connections, make sure everything is where it should be, nothing has slipped and everything is tight. Reload the tune and go from there. If the light persists, contact AM. You can get the code pulled for free at Autozone and other stores in the event it still doesn't go away and you need to trouble shoot further.
Nuke is offline   Reply With Quote
Old 08-20-2010, 07:39 AM   #4  
07VistaChicago
2nd Gear Member
 
07VistaChicago's Avatar
 
Join Date: Oct 2009
Location: Naperville, Illinois
Posts: 279
Default

Where are you at in Chicago, I have a code reader.
07VistaChicago is offline   Reply With Quote
Old 08-20-2010, 07:52 AM   #5  
S197steve
4th Gear Member
 
S197steve's Avatar
 
Join Date: Dec 2007
Location: TEXAS
Posts: 1,488
Default

Quote:
Originally Posted by 07VistaChicago View Post
Where are you at in Chicago, I have a code reader.
His SCT tuner should also be a code reader...

Also, do you have cats? If not then you need to make sure your tune accounts for that. If not, then you'll get a CEL.

One last thing, just clear the codes with the SCT. I had the same issue after I removed my 87 tune and uploaded my 93 tune from Brenspeed. Once I cleared it, the CEL never came back.
S197steve is offline   Reply With Quote
Old 08-20-2010, 10:22 AM   #6  
Jmoss
2nd Gear Member
Thread Starter
 
Jmoss's Avatar
 
Join Date: Aug 2006
Location: Chicago, IL
Posts: 331
Default

I did pull the tune from the "Custom Tune" option. Everything is stock except for my mufflers. And I cleared the codes but the light still persists. I drove about 25 miles with her just now and i feel like my acceleration is lacking compared to the stock tune... ?
Jmoss is offline   Reply With Quote
Old 08-20-2010, 10:45 AM   #7  
S197steve
4th Gear Member
 
S197steve's Avatar
 
Join Date: Dec 2007
Location: TEXAS
Posts: 1,488
Default

Quote:
Originally Posted by Jmoss View Post
I did pull the tune from the "Custom Tune" option. Everything is stock except for my mufflers. And I cleared the codes but the light still persists. I drove about 25 miles with her just now and i feel like my acceleration is lacking compared to the stock tune... ?
I'd double check the installation then... is the MAF sensor properly installed? You running the right octane for the tune?

Also, check the actual code by clicking the "Read DTC" option on your tuner. It should give you a code like P0113 or something. Then you can google that code and find out what it specifically means.

Last edited by S197steve; 08-20-2010 at 10:58 AM.
S197steve is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1992 Summer Edition - Wont start! labudski 5.0L (1979-1995) Mustang 2 08-24-2015 07:23 AM
crank position sensor 2004 mustang 3.9 v6 microgt V6 (1994-2004) Mustangs 2 08-20-2015 07:12 AM
dealership issue mweiland General Tech 6 08-13-2015 05:11 PM
Fuel pump not priming!! HELP drumhedd2005 2005-2014 Mustangs 2 08-13-2015 09:59 AM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 12:59 PM


Tags
2012, 302, auto, boss, check, chicagoil, engine, find, free, light, mustang, shop

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.