2006 Auto Stalling - MustangForums.com



4.6L V8 Technical Discussions Any questions about engine, transmission, or gearing can be asked here!
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 11-17-2012, 12:02 AM   #1
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default 2006 Auto Stalling

I was just driving along in a parking lot and my car all of a sudden just stalled. I start it back up go to put it in drive stalls again. Seems every time I let off the gas to come to a stop it stalls. Its not trowing any codes so I honestly have no clue what the problem is. I have noticed the battery dying out of nowhere lately, its kind of a hit and miss sometimes its stays charged and sometimes doesn't. Im thinking its the alternator but I had it tested recently and it came back ok. What else could cause this?
Justinsmt88 is offline   Reply With Quote
Old 11-17-2012, 06:15 AM   #2
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

As far as the charging system, you'll find the OE alternator and battery are 2 weak links in an otherwise decent vehicle. Have both tested. The cooler weather likely has caused a barely marginal system to rear it's ugly head.

The stalling can be a number of thinks but I strongly suggest that you clean the TB and replace the fuel filter first. Cleaning the MAF might be worthwhile but I doubt that's the culprit. After those, I'd run a tank of SeaFoam mix or a good fuel system cleaner (i.e., Techron). If those don't do it, let us know.

Have you modded the engine?
Nuke is offline   Reply With Quote
Old 11-17-2012, 08:23 PM   #3
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default

My car sat for two months without being ran so I changed the fuel filter and have since ran two seafoam treatments through it because of that nasty gas that was in the tank. The car runs a lot better but this issue seemed to pop up out of nowhere. Is it safe to use TB cleaner on the maf? I know these are pretty delicate and expensive to replace. I'm going to stop at autozone tomorrow to test the electrical system. But a new issues arised today, I was coming to a stop then the car accelarated on its own in three bursts then stalled while I was braking. Now when I come to a stop it does that or the tac bounces between 620-2500 rpm a few times. Damn thing is possessed!
Justinsmt88 is offline   Reply With Quote
Old 11-17-2012, 08:25 PM   #4
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default

No mods to the engine except a cold air intake and my 93 octane sct tune.
Justinsmt88 is offline   Reply With Quote
Old 11-17-2012, 08:27 PM   #5
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default

Could it be the torque converter slipping? Or something transmission related?
Justinsmt88 is offline   Reply With Quote
Old 11-17-2012, 10:12 PM   #6
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

From your description, I'm still thinking dirty TB. It doesn't take much to make these engines stumble and hunt.
Nuke is offline   Reply With Quote
Old 11-18-2012, 04:28 PM   #7
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default

Yep that was the stalling issue. Fixed the rough idle as well. No how do you clean the MAF exactly? Is it safe to use carb/tb cleaner on it?
Justinsmt88 is offline   Reply With Quote
Old 11-18-2012, 05:59 PM   #8
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

If you've resolved the issue, I'd leave the MAF alone. I've yet to clean the MAF on my GT or my wifes Pony but I have cleaned them on my SUV's and usually all they required was being sprayed down with contact cleaner. Some people will take a toothbrush to them but I've not had one that dirty. Don't fix what's not broken.
Nuke is offline   Reply With Quote
Old 11-18-2012, 08:11 PM   #9
JCON
5th Gear Member
 
JCON's Avatar
 
Join Date: Jul 2009
Location: Delaware
Posts: 2,217
Default

Do not use TB cleaner on the MAF. Only use MAF or (electronics) contact cleaner.
JCON is offline   Reply With Quote
Old 11-18-2012, 10:59 PM   #10
Justinsmt88
2nd Gear Member
Thread Starter
 
Join Date: May 2012
Location: Ohio
Posts: 315
Default

Ok im just going to leave it alone then. Thanks for the help!
Justinsmt88 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
extnesion for radio antenna to head unit kevsgt 2005-2014 Mustangs 5 10-09-2015 10:12 PM
Bad cylinder? Dathan V6 (1994-2004) Mustangs 4 10-05-2015 05:52 AM
New guy in AZ. First Mustang, First Manual, First car. BeatnikFink New Member Area 6 10-01-2015 08:00 PM
swapping trannys 2poor4u2 V6 (1994-2004) Mustangs 1 09-26-2015 11:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:32 AM.