Bad Altenator - MustangForums.com

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Bad Altenator

Old 02-25-2005, 02:28 PM
  #1  
luckypballer
2nd Gear Member
Thread Starter
 
Join Date: Nov 2004
Location: Wichita, Kansas
Posts: 383
Default Bad Altenator

So i found out today my altenator is ****. I was just wondering would having a crappy alternator cause my car to suddenly die after about 30min. of off and on driving? And how many amps would you guys recomend for my new one????
luckypballer is offline  
Old 02-25-2005, 02:33 PM
  #2  
pena8759
1st Gear Member
 
Join Date: Feb 2005
Location:
Posts: 56
Default RE: Bad Altenator

Did your battery die as well??? What you can do with a new alt is to upgrade to a 130 amp, this should do the trick.
pena8759 is offline  
Old 02-25-2005, 03:01 PM
  #3  
stanglx2002
6th Gear Member
 
Join Date: Feb 2005
Location:
Posts: 5,205
Default RE: Bad Altenator

yeah it would kill the car

the 130 amp is the one that everyone is upgrading too
stanglx2002 is offline  
Old 02-25-2005, 03:04 PM
  #4  
luckypballer
2nd Gear Member
Thread Starter
 
Join Date: Nov 2004
Location: Wichita, Kansas
Posts: 383
Default RE: Bad Altenator

it has been pissing me off, im almost 99% sure it is the alternator because the battery is a 1 month old optima. I will start fine but if i drive it for to long it will just die, and it is hard as hell to start up again
luckypballer is offline  
Old 02-25-2005, 03:05 PM
  #5  
stanglx2002
6th Gear Member
 
Join Date: Feb 2005
Location:
Posts: 5,205
Default RE: Bad Altenator

take it to a auto parts store and have them check it
stanglx2002 is offline  
Old 02-25-2005, 05:30 PM
  #6  
vfast
I ♥ Acer
 
Join Date: Jul 2003
Location:
Posts: 11,394
Default RE: Bad Altenator

anything that 130+ amps
vfast is offline  
Old 02-26-2005, 03:14 AM
  #7  
JaxJags88GT
1st Gear Member
 
Join Date: Feb 2005
Location:
Posts: 50
Default RE: Bad Altenator

i'm guessing you have underdrive pulley's on right? if you do, get the 130 amp alternator or put your stock alternator pulley back on if you go back to the 60 amp alternator.
JaxJags88GT is offline  
Old 02-26-2005, 03:17 PM
  #8  
luckypballer
2nd Gear Member
Thread Starter
 
Join Date: Nov 2004
Location: Wichita, Kansas
Posts: 383
Default RE: Bad Altenator

no underdrive pulleys, but what i was thinking about just getting them while i have the alternator off
luckypballer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dathan
V6 (1994-2004) Mustangs
4
10-05-2015 06:52 AM
KingRando
2005-2014 Mustangs
5
10-02-2015 09:06 AM
UrS4
S197 Handling Section
1
09-30-2015 11:13 AM
MustangForums Editor
GT350 S550 Tech
1
09-29-2015 04:29 PM
GLOCKer
General Tech
0
09-28-2015 08:36 AM


Thread Tools
Search this Thread
Quick Reply: Bad Altenator


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.