Trick flow top end idle problems and runs rich - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 02-25-2017, 10:31 AM   #1
schecterplayer
1st Gear Member
Thread Starter
 
Join Date: Jul 2012
Location: MD
Posts: 65
Default Trick flow top end idle problems and runs rich

I have finished installing the trick flow stage one kit and the car is a monster now! I am having problems though with how it starts and idles. The car will fire right up but never seems to go to fast idle like a car does when it's cold. And when the car is warmed up it doesn't really have a solid start if that makes sense. It fires but it feels weak. When the car is cold it will fumble and almost die but usually recovers and idles fine. I have tried to reset the base idle and that seemed to help some. I have checked everything possible for a vacuum leak and can't find any.I have pulled codes and have nothing but the canister purge That was removed.Same with keor, no codes. I have 24lb Injectors paired with the 24lb pro m mass air. I got a tune from bama that made the car run much better The car is also running rich, I can tell by the smell. Sorry for the long winded post but does anyone have any ideas?
schecterplayer is offline   Reply With Quote
Old 02-25-2017, 12:59 PM   #2
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,480
Default

You got a canned tune from bama, take it someplace that can dyno tune it. Or just put some miles on it and see if the adaptive learning will level it all out.

The exhaust is going to smell rich if you have an after market catless exhaust. Smell is not an indication of lean or rich, if it is truely running overly rich it smoke black out of the exhaust.
dawson1112 is online now   Reply With Quote
Old 02-26-2017, 11:46 AM   #3
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,767
Default

Quote:
Originally Posted by schecterplayer View Post
\ The car is also running rich, I can tell by the smell.
no you can't......that mean nothing, unless you have a wideband on it, you nose is not a calibrated indicator, expecially if the cats are removed, mine 89 s/c vert smells rich all the time as well but the wideband tells a different story= the truth. best way to check for vac leaks is find someone with a smoke machine
mjr46 is offline   Reply With Quote
Old 02-26-2017, 04:59 PM   #4
schecterplayer
1st Gear Member
Thread Starter
 
Join Date: Jul 2012
Location: MD
Posts: 65
Default

OK thanks. I was driving around today and the car drives fine but when I come to a stop the engine dips down below normal idle and almost dies. Sometimes actually does die and it's then hard to start back up. Any ideas??
schecterplayer is offline   Reply With Quote
Old 02-26-2017, 06:23 PM   #5
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,480
Default

Quote:
Originally Posted by schecterplayer View Post
OK thanks. I was driving around today and the car drives fine but when I come to a stop the engine dips down below normal idle and almost dies. Sometimes actually does die and it's then hard to start back up. Any ideas??
How long has the MAF been on the car, and are you running a hi flow air filter? The air filters with oil on them can sometimes contaminate the MAF with oil. Try cleaning it with some MAF cleaner spray. Also make sure you not leaking air any where on the cold air intake tube after the MAF.
dawson1112 is online now   Reply With Quote
Old 02-27-2017, 10:22 AM   #6
schecterplayer
1st Gear Member
Thread Starter
 
Join Date: Jul 2012
Location: MD
Posts: 65
Default

Quote:
Originally Posted by dawson1112 View Post
How long has the MAF been on the car, and are you running a hi flow air filter? The air filters with oil on them can sometimes contaminate the MAF with oil. Try cleaning it with some MAF cleaner spray. Also make sure you not leaking air any where on the cold air intake tube after the MAF.
The maf is new. Never had the stock maf have oil on it so I dont think that's the issue but good suggestions
schecterplayer is offline   Reply With Quote
Old 02-27-2017, 11:39 AM   #7
lxman1
4th Gear Member
 
Join Date: Jan 2008
Location: Louisville, Ky.
Posts: 1,324
Default

How old is the IAC? It may be sticking or too slow to keep up with the idle needed
lxman1 is offline   Reply With Quote
Old 02-27-2017, 04:23 PM   #8
schecterplayer
1st Gear Member
Thread Starter
 
Join Date: Jul 2012
Location: MD
Posts: 65
Default

Quote:
Originally Posted by lxman1 View Post
How old is the IAC? It may be sticking or too slow to keep up with the idle needed
it's a year old. Not a oem part but the stock setup idled good. I did the base idle reset process today and actually let the car get to operating temp before replugging the iac in. Seemed to fix the idle issues. Still cold start has a little issues but idle seems good
schecterplayer is offline   Reply With Quote
Old 02-28-2017, 03:51 PM   #9
schecterplayer
1st Gear Member
Thread Starter
 
Join Date: Jul 2012
Location: MD
Posts: 65
Default

And after I did the correct process of resetting the idle the car cold start's like new. Thanks for all the suggestions everyone! This should be well known throughout our forums that if you hci swap RESET YOUR IDLE WITH THE ENGINE WARM!
schecterplayer is offline   Reply With Quote
Old 03-13-2017, 04:26 PM   #10
yurizx6r
3rd Gear Member
 
yurizx6r's Avatar
 
Join Date: Sep 2011
Location: Florida
Posts: 612
Default

That certainly helps! lol But I would still take it to a local tuner who can tune YOUR car. Bama will get you moving, but it's not a good tune doing it from another state just taking wild shots and guesses. I had the same thing happen to me when I put in my 331 stroker motor with all bolt ons. Took it to a local tuner and made a night and day difference. Worth it.
yurizx6r is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:00 AM.