backfiring carb? - MustangForums.com

General Tech Ask model specific questions in the appropriate category below. All other general questions within.

backfiring carb?

Reply

 
 
 
Old 07-24-2006, 01:12 PM
  #1  
JayStang65
Thread Starter
 
Join Date: Jul 2006
Location:
Posts: 23
Default backfiring carb?

i have 65 fastback with a 289 hi-po, it was running fine i was in 4th going about 45-50 mph and i started hearing this like banging sound when ever i gave it gas and if i took my foot off the accelerator it would go away. i kno its coming from the carb but i dont kno what would make it do this?
JayStang65 is offline  
Reply With Quote
Old 08-31-2006, 07:59 AM
  #2  
kalebiscool
 
Join Date: Aug 2006
Location:
Posts: 12
Default RE: backfiring carb?

could have bent valve.cam may have gone down(those do have solid cams)timing chain could have slipped....unlikely, they usually just break.distributor gear, cap, rotor.check the plugs and wires first, then the distributor cap.and please god tell me you dont still have points ignition.cause that is junk.
kalebiscool is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bradleyb
Classic Mustangs (Tech)
3
11-27-2015 07:50 PM
bradleyb
California Regional Chapter
0
10-01-2015 01:02 AM
Sminemann
Classic Mustangs (Tech)
7
09-17-2015 09:24 AM
Daddys Girls GTs
5.0L (1979-1995) Mustang
3
09-14-2015 08:46 PM
jaiidutch
Motor Swap Section
2
09-14-2015 10:29 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory