whipple problems - MustangForums.com



GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 08-17-2007, 02:32 PM   #1
fadetoblack172
1st Gear Member
Thread Starter
 
Join Date: Apr 2007
Location:
Posts: 121
Default whipple problems

i have an 07 gt and in june i bought the whipple non-intercooled system from cj pony parts and had them install it....a week later the serpintine belt snapped ripping the hood liner all up....a week and a half later they had it fixed with a different idler pully....but it squealled horribly everytime i started it.... so i took it back yet again and had the original idle pully put back on and two days later the belt snapped again.....both breaks occured at a shift.. so they came and picked it up again.....this is the third time it has been back to the shop....its been a week and a half and my car isn't fixed yet....i am very un satisfied with this system and the service that i have recieved[:@]
fadetoblack172 is offline   Reply With Quote
Old 08-17-2007, 02:37 PM   #2
Dex
5th Gear Member
 
Dex's Avatar
 
Join Date: Mar 2007
Location:
Posts: 2,257
Default RE: whipple problems

shoulda got a turbo

hope you get it figured out
Dex is offline   Reply With Quote
Old 08-17-2007, 03:00 PM   #3
hammeron
6th Gear Member
 
hammeron's Avatar
 
Join Date: May 2006
Location: Nicely done
Posts: 11,777
Default RE: whipple problems

hang in there, everything is gonna be fine...

now, it sounds like an alignment issue with the belt. you
may need to have CJ get with whipple, to install
a shim behind the s/c pulley. this will bring the pulley
out a tiny bit towards the front of the car.

good luck and please keep us updated, those of us
with the whipples would be interested in how you get
your issue resolved.



hammeron is offline   Reply With Quote
Old 08-17-2007, 03:06 PM   #4
fadetoblack172
1st Gear Member
Thread Starter
 
Join Date: Apr 2007
Location:
Posts: 121
Default RE: whipple problems

no its not the allignment they said something about the tensioner was not set right??? i'm very pissed .... the service i'm getting sucks i'm on the phone everyday trying to get my car fixed i'm about ready to tell them to take it off and give me my money back cuz i didnt pay them 5500 bucks for my car to break every week .. and they're not even compensating me in any way for all this crap i've been put through..
fadetoblack172 is offline   Reply With Quote
Old 08-17-2007, 03:21 PM   #5
hammeron
6th Gear Member
 
hammeron's Avatar
 
Join Date: May 2006
Location: Nicely done
Posts: 11,777
Default RE: whipple problems

i do hope your problem gets solved.

this is why i spent 8 days doing it myself, if
it was gonna give me grief, i wanted it to be because
of me


hammeron is offline   Reply With Quote
Old 08-17-2007, 03:29 PM   #6
fadetoblack172
1st Gear Member
Thread Starter
 
Join Date: Apr 2007
Location:
Posts: 121
Default RE: whipple problems

well aparently art whipple was rushed to the hospital wednesday night and he was the one handling this whole thing and thats why they cant get it done today and bill at cj's said he's gonna try a belt from napa which i dont think is a good idea but o well......cuz if i have one more problem after this its coming off
fadetoblack172 is offline   Reply With Quote
Old 08-17-2007, 03:36 PM   #7
hammeron
6th Gear Member
 
hammeron's Avatar
 
Join Date: May 2006
Location: Nicely done
Posts: 11,777
Default RE: whipple problems

there is always the option to go back to
stock (hopefully someone saved all the parts)

there is another option along with the shim, it's an
8 rib system.....

hammeron is offline   Reply With Quote
Old 08-17-2007, 03:43 PM   #8
fadetoblack172
1st Gear Member
Thread Starter
 
Join Date: Apr 2007
Location:
Posts: 121
Default RE: whipple problems

yea i have all the parts...what is the 8 rib system , just an 8 rib belt and pullies?
fadetoblack172 is offline   Reply With Quote
Old 08-17-2007, 03:48 PM   #9
hammeron
6th Gear Member
 
hammeron's Avatar
 
Join Date: May 2006
Location: Nicely done
Posts: 11,777
Default RE: whipple problems

yeah pretty much.....i never really researched it, i just
know it exists from reading other message boards

if it get's to that, i can help ya find the guy who sells
them.....whipple may even sell the kit now, not sure

hammeron is offline   Reply With Quote
Old 08-17-2007, 04:41 PM   #10
blackhorse05
I ♥ Acer
 
Join Date: Mar 2005
Location:
Posts: 1,060
Default RE: whipple problems

what belt r u using. by that i mean brand.make sure the pullies are alligned, and go to ford and buy F7UZ-8509-AA . its a bigge w/p pulley, it will help the belt wrap the s/c a bit better
blackhorse05 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Power Adder Sale Granatelli Sales Vendor For Sale / Group Buy Classifieds 9 03-21-2016 06:16 PM
2007 Won't stay running -- Possible electric problem Seanam V6 S197 General Discussion 5 10-04-2015 10:15 AM
1996 GT Studdering problems.. Need Help stangin1996gt 4.6L (1996-2004 Modular) Mustang 0 09-21-2015 11:01 AM
O2 sensors Big Al's 03 Mach 1 Section 4 09-21-2015 07:59 AM
Huge Savings from Lethal Performance.com!(Whipple, McLeod, Kooks, & MUCH MORE..) Boostaddict Lethal Performance 2 09-08-2015 09:56 PM


Tags
1247kg, 1247kgdayco, 209770, belt, belts, boost, cobra, dayco, instructions, m5230s, problem, problems, size, throwing, whipple

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 07:56 AM.