02 sensors - MustangForums.com

Mach 1 Section This section is for discussions relating to the reincarnation of the Mach 1 trimline.

02 sensors

Reply

 
 
 
Old 08-11-2007, 09:31 PM
  #1  
Machmax777
1st Gear Member
Thread Starter
 
Join Date: Aug 2007
Location:
Posts: 134
Default 02 sensors

I put a off road x pipe on my 04 mach1 and installed steeda mil eleminators. like a dummy i wiped of the 02 sensors with my hands and of course 3 days later they went bad and the check engine light came on. about 2 weeks later i replaced the bad 02's with 4 new bosh. today the light came back on[:@]. im clueless to what the heck is going on. thanks for any help.
Machmax777 is offline  
Reply With Quote
Old 08-12-2007, 12:38 AM
  #2  
Donnie's GTS
4th Gear Member
 
Donnie's GTS's Avatar
 
Join Date: Jul 2006
Location: SoCal
Posts: 1,030
Default RE: 02 sensors

you need to get the mil eliminators, your o2's aren't going bad, they are just going crazy with the extremely thick mixture of engine fumes.
Donnie's GTS is offline  
Reply With Quote
Old 08-12-2007, 09:51 AM
  #3  
Machmax777
1st Gear Member
Thread Starter
 
Join Date: Aug 2007
Location:
Posts: 134
Default RE: 02 sensors

what do you meen i need to get the mil eliminators? i already have them on
Machmax777 is offline  
Reply With Quote
Old 08-26-2007, 07:35 PM
  #4  
wakin3722
 
Join Date: Jul 2006
Location:
Posts: 40
Default RE: 02 sensors

I installed BBK mil eliminators. And I haven't had any problems.I would try returning or exchangingthe mil eliminators. Maybe that would fix it.
wakin3722 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jwog666
Pipes, Boost & Juice
6
01-07-2018 07:16 AM
Dathan
V6 (1994-2004) Mustangs
4
10-05-2015 05:52 AM
mrtrodonet
V6 (1994-2004) Mustangs
1
09-29-2015 11:13 AM
Big Al's 03
Mach 1 Section
4
09-21-2015 07:59 AM
TfcCDR
V6 (1994-2004) Mustangs
1
09-14-2015 12:08 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory