Check engine light p0430 confusion! - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang > SVT Forums
Reload this Page >

Check engine light p0430 confusion!

SVT Forums

Check engine light p0430 confusion!

Reply

 
 
 
Old 08-31-2015, 01:59 AM
  #1  
Scottyboy187
Thread Starter
 
Join Date: May 2015
Location: Illinois
Posts: 22
Default Check engine light p0430 confusion!

I have a 97 Cobra. 33k miles. It has an offroad catless BBK H-pipe and MIL eliminators. My check engine light came on with a p0420 code (bank 1 passenger side catalyst efficiency low) so I switched the sides of my O2 sensors (left to right and right to left). Both the front and rear. The cel came up again but with a p0430 code (bank 2 driver side) after the switch. I figured I had a bad sensor so I bought new ones for the driver side (front and rear). The P0430 code appeared again with the CEL, so I switched sides of only the mil eliminators and no change - still the p0430. By the way the MILS are from American muscle. None of this is adding up, I hope someone can help!
Thanks
P.s. It seems like more exhaust vapors are coming from the drivers side tailpipe rather than the passenger side. I can also smell the exhaust fumes a lot. It might be running rich but I am not getting bad gas mileage (roughly 18mpg). When I pulled the O2 sensors out they were black. Not sure if that has anything to do with my problem. Not even sure if I am running rich or not.

Last edited by Scottyboy187; 08-31-2015 at 02:10 AM.
Scottyboy187 is offline  
Reply With Quote
Old 09-02-2015, 03:03 AM
  #2  
Scottyboy187
Thread Starter
 
Join Date: May 2015
Location: Illinois
Posts: 22
Default

No one??? I might have a leaky injector or bad fuel pressure regulator
Scottyboy187 is offline  
Reply With Quote
Old 11-20-2015, 03:34 PM
  #3  
1996cobraconvertible
 
Join Date: Aug 2015
Location: NJ
Posts: 33
Default Not sure if this helps...

I went and bought a 96 Cobra. The guy originally had taken off the cats and ran straight. I did not want this so I told the guy to put the old cats back on. The night I picked the car up the cel was on, he said that was because it needed an 02 sensor. Made sense. I used to have a scanner but not the newer ones, went over to Autozone they send out a girl, she runs it and I get 02 sensor code. Long story short. I had another scan on it and it was coming up with two scans. The second scan was a relay which triggered the 02 bad. I never needed an 02 sensor. Moral of the story is make sure your scans are correct. So far for me so good. In the mean time I put all new exhaust with hi flo cats.


Sorry this is all I can help you with. If you are interested in what the relay was, I can check at home. Just let me know.
1996cobraconvertible is offline  
Reply With Quote
Old 11-20-2015, 03:57 PM
  #4  
Scottyboy187
Thread Starter
 
Join Date: May 2015
Location: Illinois
Posts: 22
Default

Originally Posted by 1996cobraconvertible View Post
I went and bought a 96 Cobra. The guy originally had taken off the cats and ran straight. I did not want this so I told the guy to put the old cats back on. The night I picked the car up the cel was on, he said that was because it needed an 02 sensor. Made sense. I used to have a scanner but not the newer ones, went over to Autozone they send out a girl, she runs it and I get 02 sensor code. Long story short. I had another scan on it and it was coming up with two scans. The second scan was a relay which triggered the 02 bad. I never needed an 02 sensor. Moral of the story is make sure your scans are correct. So far for me so good. In the mean time I put all new exhaust with hi flo cats.


Sorry this is all I can help you with. If you are interested in what the relay was, I can check at home. Just let me know.
Thank you for your response! However I put spark plug de foulers on my o2 sensors and my cel has been gone ever since
Scottyboy187 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
labudski
5.0L (1979-1995) Mustang
2
08-24-2015 08:23 AM
microgt
V6 (1994-2004) Mustangs
2
08-20-2015 08:12 AM
mweiland
General Tech
6
08-13-2015 06:11 PM
drumhedd2005
2005-2014 Mustangs
2
08-13-2015 10:59 AM
djbigskrilla
2005-2014 Mustangs
13
08-11-2015 01:59 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory