My v6 Mustang has a problem nobody can find or fix - MustangForums.com



V6 General Discussion This section is for non-tech specific information pertaining to V6 Mustangs.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-15-2016, 08:22 AM   #1
brandon1233481
Thread Starter
 
Join Date: Oct 2016
Location: PA
Posts: 1
Unhappy My v6 Mustang has a problem nobody can find or fix

Hello Everyone I just wanted to make this post because I am now out of ideas. Nobody can help me anymore with my 1999 v6 mustang. The problem is it has this low idle. It will be sitting at 800 rpm and then it will go down to 600 and realize its to low and jump up to 800 again. I does this every like 5 seconds and only when it warms up! At cold it will stay at around 900 for the most part. But the thing is when it does this you can see the engine sake side to side for 1 second before it jumps back up to 800 rpms. The odd part is when driving if you try to accelerate quick it will kind of hiccup or misfire like it loses gas for like half a second I have been to 3 shops including the dealership and no success. The new mechanic says he is almost certain it is the ecu. But idk anymore!!!! Here is what I have replaced.

Fuel pump
Fuel filter
Ran some injector cleaner
New crank sensor
New spark plugs, Wires, and Ignition Coil pack
Could not locate any vacuum leaks
Cleaned mass air flow sensor
Car throws no codes

It just makes no ****ing sense. Also all this started AROUND the time my buddy hooked the battery up backwards when he jumped it. But my dilemma is the car still runs and while ****ty will accelerate and idle without stalling it is just so bad!!!! If you listen to the exhaust you can here it puttering and sputtering
My question is what the **** is this problem!!! does a ECU even make any sense. I don't know what to do or what to believe anymore. I have put 4 thousand into this car and I paid 3500 for it! Can anyone help me or have any good info please. Thank you guys
brandon1233481 is offline   Reply With Quote
Old 01-30-2017, 01:37 AM   #2
CacaGirl520
 
Join Date: Jan 2017
Location: AZ
Posts: 2
Default

try replacing the fuel rail pressure sensor
CacaGirl520 is offline   Reply With Quote
Old 01-30-2017, 10:40 AM   #3
TRamsdell
2nd Gear Member
 
TRamsdell's Avatar
 
Join Date: May 2016
Location: Ny
Posts: 348
Default

vehicle info?
TRamsdell is online now   Reply With Quote
Old 01-30-2017, 10:41 AM   #4
TRamsdell
2nd Gear Member
 
TRamsdell's Avatar
 
Join Date: May 2016
Location: Ny
Posts: 348
Default

Quote:
Originally Posted by brandon1233481 View Post
The new mechanic says he is almost certain it is the ecu.
it's almost never the ecu.
TRamsdell is online now   Reply With Quote
Old 01-30-2017, 02:33 PM   #5
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,402
Default

Sad to hear you have put that much money into your car.

I made that mistake once and never again.
movielover40 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How to make a faster horse (2015-2017 Mustang GT) smecla 5.0L GT S550 Tech 10 09-27-2016 11:00 AM
How to make a faster horse (2015-2017 Mustang GT) smecla General Tech 6 08-30-2016 07:59 PM
Are cat backs all sound or do they make HP? doubleoh GT S197 General Discussion 13 08-19-2016 12:09 PM
do they make cams for 2005-2009 4.0 mustangs? 4.o stang 4.0L V6 Technical Discussions 10 08-16-2016 07:57 AM
5.4liter out of a 1999 f-250 Running problems. Young Stallion 4.6L (1996-2004 Modular) Mustang 1 07-29-2016 05:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:35 PM.