Notices
V6 S197 General Discussion This section is for technical discussions pertaining specifically to the V6 variation of the 2005 and newer Ford Mustang.

Climate Control System

Old 09-13-2014, 08:48 PM
  #1  
joshiemitsue
Thread Starter
 
Join Date: Sep 2014
Location: Virginia
Posts: 2
Default Climate Control System

Hey guys, I just bought my 2008 v6 mustang and i lost power to my climate control system after doing maintenance on it. of course i think it happened because had to disconnect the battery for a few things. (of course i reconnected it) Weird thing is that the a/c and heat section does not light up as well. I checked all my fuses. they all have current. I went behind the center panel and reset the plug to it. Yet, it still does not work. I could replace the fuses but while i still research, just wondering if anyone has any input to my situation. I hope this makes sense to people.
joshiemitsue is offline  
Old 09-15-2014, 07:05 AM
  #2  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Either you haven't described the problem well or you have an issue that's never been discussed before.
Nuke is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
folivier
New Member Area
4
10-02-2015 05:34 AM
ChampInSD
5.0L GT S550 Tech
13
10-02-2015 04:55 AM
AMAlexLazarus
AmericanMuscle.com
0
10-01-2015 09:21 AM
bradleyb
California Regional Chapter
0
10-01-2015 01:02 AM
mrtrodonet
V6 (1994-2004) Mustangs
1
09-29-2015 11:13 AM


Thread Tools
Search this Thread
Quick Reply: Climate Control System


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.