Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-30-2011, 07:05 PM   #1
StevoX1
1st Gear Member
 
Join Date: Aug 2006
Vehicle: 93 Mustang LX Hatch
Location: CA
Posts: 107
Default Power window won't go up

The passenger side window has been a little hesitant to go up recently when fully down, usually takes a couple clicks of the window control for it to go yet finally today she seized up, stuck in the door. Im curious as to if its the actual window control which i kinda doubt since neither controls on driver or passenger side work so im assuming the window motor finally gave out. Driver side window goes up fine but the passenger is shot.

Any suggestions on how to remedy the situation or just to get it back up for the time being would be appreciated. Thanks.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________
93 LX 5.0, aluminum radiator, BBK CAI, JBA shorty ceramic headers, magnaflow x pipe and cats, two chamber flowmasters, catback, 3"tips, more to come.

Last edited by StevoX1; 07-30-2011 at 07:10 PM.
StevoX1 is offline   Reply With Quote
Old 07-30-2011, 10:37 PM   #2
rtintwo
2nd Gear Member
 
Join Date: Aug 2009
Vehicle: 1970 Mach 1
Location: Nebraska
Posts: 475
Default

Start with the basics of your fuses, i doubt this is the case sense the driver side works but doesnt hurt to check.


If fuse is good then, key in run position, push the up side of the button and hit the bottom of the door with a rubber mallet. Alot of the time the brushes on the ford window motors will get some corrosion and stop working, hitting the bottom of the door will free the motor up to work for a short time(to get the window closed). If hitting the door gets the window to move then you need to replace the motor at your convenience.

If hitting doesnt work. Pull the switch out of the door. Using a test light make sure you have power into the switch and then check that you have power out when you hit the button. Should be one power in and two powers out, one for window up and one for window down. If the passenger door doesnt have this then say so and we can go from there.

If hitting doesnt work and power is good pull the door panel off and look at the regulator to see what is broken on it.
rtintwo is offline   Reply With Quote
Old 07-31-2011, 12:55 PM   #3
holyshift
3rd Gear Member
 
holyshift's Avatar
 
Join Date: Jul 2007
Vehicle: 1988,Ford,Mustang
Location: Sandusky,OH
Posts: 893
Default

Mine just did this same thing about a month ago. Tore it all apart,found that power was getting to switches,etc. Smacked right were the motor is mounted with a hammer and it freed up. Dont know if it was in a bind or what but its been fine since. I dont roll my windows down all the way most of the time but its seemed to be ok.
__________________

88 Hatch,Long Rod 308(Scat crank,Oliver Rods,JE Pistons,9.7:1 comp),GT40 SVO Heads,Crane Cam,1.7 rockers,Port matched Vic Jr,650 Holley,plate kit,4r70w,custom converter,Best ET to date: 10.84 @122mph with a 1.45 60'.63n/51f
Yea Dude Racing Big Kid Racing
February 2012 UPR Ride of the Month
holyshift is offline   Reply With Quote
Old 08-01-2011, 10:51 PM   #4
buster
4th Gear Member
 
Join Date: Aug 2005
Vehicle: 2001 grand prix gtp - had to sell the slow stang
Location: alberta, canada
Posts: 1,887
Default

Quote:
Originally Posted by holyshift View Post
Mine just did this same thing about a month ago. Tore it all apart,found that power was getting to switches,etc. Smacked right were the motor is mounted with a hammer and it freed up. Dont know if it was in a bind or what but its been fine since. I dont roll my windows down all the way most of the time but its seemed to be ok.
How is Norwalk doing? i haven't been this year. It sucks that there is no Ford race this year. By far my favorite track. NMRA was at Milan this year and the employees there are so friendly (sarcasm). I'm definitely not going to NMCA there.
__________________
um, it's red.....hey I just got it, gimme a chance
buster is offline   Reply With Quote
Old 08-03-2011, 06:21 PM   #5
holyshift
3rd Gear Member
 
holyshift's Avatar
 
Join Date: Jul 2007
Vehicle: 1988,Ford,Mustang
Location: Sandusky,OH
Posts: 893
Default

Quote:
Originally Posted by buster View Post
How is Norwalk doing? i haven't been this year. It sucks that there is no Ford race this year. By far my favorite track. NMRA was at Milan this year and the employees there are so friendly (sarcasm). I'm definitely not going to NMCA there.
Ehh Norwalk lately hasnt been so good,its all about the bracket racers,no heads up races,no index,no Ford race,no Chevy race....really I dont like going there any more. Just to test the car,have been trying to make it to Milan to race 11.0 index and enjoy some outlaw cars such as X275 and what have ya. I have heard ups and downs about Milan,but at least they have entertaining races to participate in and spectate.
__________________

88 Hatch,Long Rod 308(Scat crank,Oliver Rods,JE Pistons,9.7:1 comp),GT40 SVO Heads,Crane Cam,1.7 rockers,Port matched Vic Jr,650 Holley,plate kit,4r70w,custom converter,Best ET to date: 10.84 @122mph with a 1.45 60'.63n/51f
Yea Dude Racing Big Kid Racing
February 2012 UPR Ride of the Month
holyshift is offline   Reply With Quote
Old 08-03-2011, 06:43 PM   #6
Boss_Hotrod
4th Gear Member

 
Join Date: Apr 2006
Vehicle: 93 Mustang LX, 13 Boss 302
Location: NC
Posts: 1,994
Default

More than likely the nylon bushings in the motor are shot since you said it was getting sluggish. To remedy this remove the motor and take off the cover around the gear. Clean everything up and replace the bushings or put it 6 5/16" nuts in stack of 2 where the bushings were. If doing this dont get your fingers caught in the glass. You should be able to get the bushings at Napa for a few bucks. Once fixed the motor will continue to run for years.
Be sure to regrease the gears.
Boss_Hotrod is online now   Reply With Quote
Old 08-03-2011, 06:43 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
1993, 1995, 2006, 50, 88, convertible, ford, lx, mustang, passenger, power, rear, roll, widow, window, windows, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 02:10 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup