Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-13-2012, 06:54 PM   #1
Ryushi5
 
Join Date: Oct 2012
Posts: 3
Default 91 5.0 Rough Idle, Dying Engine Codes 15, 33

I have a 91 5.0 that is unmodified from stock save for the headers and exhaust. It was running fine and then one morning it was idling very rough and dying. No changes were made to the vehicle to my knowledge.

First thing I did was run fuel injector cleaner through it just hoping it may be a dirty injector. No dice.

KOEO codes are 15 and 33. No KOER codes.

What should I check next to track this problem down?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
Ryushi5 is offline   Reply With Quote
Old 10-13-2012, 07:12 PM   #2
mattdel
6th Gear Member
 
mattdel's Avatar
 
Join Date: Nov 2006
Vehicle: 1986 LX, 87 GT Hatch, 89 GT Vert
Location: Spfld, MA
Posts: 9,240
Send a message via AIM to mattdel
Default

Code 15 indicates that the ROM inside the computer has failed.
Code 33 indicates that the EGR was commanded to move but failed to do so.

Start with 15, it's likely the cause of 33. New computer can be purchased through rockauto.com for around $100
__________________
mattdel is offline   Reply With Quote
Old 10-15-2012, 01:33 PM   #3
Ryushi5
 
Join Date: Oct 2012
Posts: 3
Default

From what I've read the code 15 can either be an ECU failure or improper voltage supplied to the ECU. The voltage from pin 1 to ground should be 12 volts, mine reads 11.86. Does anyone know if this is within acceptable range?

I also took a look at the ECU and did not see any blown resistors or bulging capacitors. Is it typical for an ECU to be bad without showing any signs of physical failure?
Ryushi5 is offline   Reply With Quote
Old 10-15-2012, 01:41 PM   #4
Ryushi5
 
Join Date: Oct 2012
Posts: 3
Default

Disregard that last question, I just realized that the error refers to the actual ROM. It's entirely possible for a ROM chip to go bad without damaged components.
Ryushi5 is offline   Reply With Quote
Old 10-15-2012, 01:41 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
code 15, code 33, idle, rough

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:59 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup