Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-19-2014, 03:17 PM   #1
Aussie24
 
Join Date: Oct 2012
Vehicle: 1995 mustang GT convertable
Location: Lousiaina
Posts: 7
Default My Mustang keeps stopping

MY 95 GT starts runs for 30 second or sometimes 2 minutes then it stops like it has run out of gas. It will start back up again but same thing
I changed the fuel filter which a lot of brown gas came out of the engine side of filter ran gas out to check it and was ok ,checked that the pump was working , New plugs and O2 senor.
There is a couple of galons of gas in the tank but the gauge is all over the place says 1/2 full then turn the key and it goes down to 1/4 tank.

Would love some advice
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
Aussie24 is offline   Reply With Quote
Old 05-20-2014, 11:01 AM   #2
88 orangepeel notch
4th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Vehicle: 1988 notchback
Location: Wisconsin
Posts: 1,875
Default

I would start by putting more gas in it, then verify you have fuel pressure around 35-40 lbs. How did you verify that your fuel pump was good?
__________________
306 with all bolt ons, letter cam, ported E7's, T5 swap, full exhaust, 3:55's, 2" drop, and the worst paint you'll ever see or feel.
Dyno'd 300/316, 2745lbs-track scale
Best ET………12.4@108, 1.66 60ft on 8" ET Drags.
24 mpg (combined)
88 orangepeel notch is offline   Reply With Quote
Old 05-20-2014, 12:01 PM   #3
Aussie24
 
Join Date: Oct 2012
Vehicle: 1995 mustang GT convertable
Location: Lousiaina
Posts: 7
Default

I took the tank side of the fuel filter off and put it in a bucket and turned the key on and it came out and stopped when I cut the power.
Aussie24 is offline   Reply With Quote
Old 05-20-2014, 03:20 PM   #4
Aussie24
 
Join Date: Oct 2012
Vehicle: 1995 mustang GT convertable
Location: Lousiaina
Posts: 7
Default

Today it started right up, Then it revered it self the went normal the went a bit more and stalled but then the radiator fan came on and I heard a clicking coming from where the relay for fuel and fan is. Could it just be the relay?
Aussie24 is offline   Reply With Quote
Old 05-21-2014, 08:25 AM   #5
88 orangepeel notch
4th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Vehicle: 1988 notchback
Location: Wisconsin
Posts: 1,875
Default

Could be the relay, but sounds like a bad ignition switch, or even a bad ECM (computer) My foxbody did this when I first bought it, traced the problem to the computer and that fixed it, but it is rare that they go out. Try wiggling the key when the problems occur. And I have no idea why your fan kicked on unless the motor was that hot.
__________________
306 with all bolt ons, letter cam, ported E7's, T5 swap, full exhaust, 3:55's, 2" drop, and the worst paint you'll ever see or feel.
Dyno'd 300/316, 2745lbs-track scale
Best ET………12.4@108, 1.66 60ft on 8" ET Drags.
24 mpg (combined)
88 orangepeel notch is offline   Reply With Quote
Old 06-02-2014, 10:49 PM   #6
aode08
5th Gear Member
 
Join Date: Oct 2005
Vehicle: 91 Mustang GT
Location: Ohio USA
Posts: 4,614
Default

Quote:
Originally Posted by Aussie24 View Post
Today it started right up, Then it revered it self the went normal the went a bit more and stalled but then the radiator fan came on and I heard a clicking coming from where the relay for fuel and fan is. Could it just be the relay?

http://www.autozone.com/autozone/par...7020_880641_0_

The above part is overheating.
Usually the result of a bad fuel pump and fuel filter.
Parts needed at this point in year

All 5 parts.fuel pump, fuel pump filter, ccrm module,coil pack,and igntion control module/tfi module, needs replaced. Use a stock fuel pump, high drian units will fry the module again.
This is a very common issue with your year car.
__________________



347 , 11:1 Compression,Knife Edged Lightened Crank,AFR 185,Ported Trick-flow Intake,Ford X-CAM,Under-drive pulleys,aluminum drive-shaft, 3:73 gears,Fender Cold Air Intake,Long tube headers,MSD Digital Ignition System
Lightened chassis.

451HP 439 FtLbTrq. mid 10 second car !
aode08 is offline   Reply With Quote
Old 07-09-2014, 07:54 PM   #7
Aussie24
 
Join Date: Oct 2012
Vehicle: 1995 mustang GT convertable
Location: Lousiaina
Posts: 7
Default

I did a pressure test on the fuel pump it read 40psi with the key on and car was cold but then the radiator fan kicked on, Why I don't know but the psi went down to 30. I started the car and the psi was just over 40.Not sure if the fan came on and car stopped or not.
What could this be
Aussie24 is offline   Reply With Quote
Old 07-10-2014, 08:34 AM   #8
88 orangepeel notch
4th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Vehicle: 1988 notchback
Location: Wisconsin
Posts: 1,875
Default

I'm not familiar with the SNs, but I'd pull codes now to see what's up. Something is amiss in Mustang Land.
__________________
306 with all bolt ons, letter cam, ported E7's, T5 swap, full exhaust, 3:55's, 2" drop, and the worst paint you'll ever see or feel.
Dyno'd 300/316, 2745lbs-track scale
Best ET………12.4@108, 1.66 60ft on 8" ET Drags.
24 mpg (combined)
88 orangepeel notch is offline   Reply With Quote
Old 07-10-2014, 08:34 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 03:25 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup