My Mustang keeps stopping - MustangForums.com



5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 05-19-2014, 02:17 PM   #1
Aussie24
Thread Starter
 
Join Date: Oct 2012
Location: Lousiaina
Posts: 7
Default My Mustang keeps stopping

MY 95 GT starts runs for 30 second or sometimes 2 minutes then it stops like it has run out of gas. It will start back up again but same thing
I changed the fuel filter which a lot of brown gas came out of the engine side of filter ran gas out to check it and was ok ,checked that the pump was working , New plugs and O2 senor.
There is a couple of galons of gas in the tank but the gauge is all over the place says 1/2 full then turn the key and it goes down to 1/4 tank.

Would love some advice
Aussie24 is offline   Reply With Quote
Old 05-20-2014, 10:01 AM   #2
88 orangepeel notch
5th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 4,977
Default

I would start by putting more gas in it, then verify you have fuel pressure around 35-40 lbs. How did you verify that your fuel pump was good?
88 orangepeel notch is offline   Reply With Quote
Old 05-20-2014, 11:01 AM   #3
Aussie24
Thread Starter
 
Join Date: Oct 2012
Location: Lousiaina
Posts: 7
Default

I took the tank side of the fuel filter off and put it in a bucket and turned the key on and it came out and stopped when I cut the power.
Aussie24 is offline   Reply With Quote
Old 05-20-2014, 02:20 PM   #4
Aussie24
Thread Starter
 
Join Date: Oct 2012
Location: Lousiaina
Posts: 7
Default

Today it started right up, Then it revered it self the went normal the went a bit more and stalled but then the radiator fan came on and I heard a clicking coming from where the relay for fuel and fan is. Could it just be the relay?
Aussie24 is offline   Reply With Quote
Old 05-21-2014, 07:25 AM   #5
88 orangepeel notch
5th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 4,977
Default

Could be the relay, but sounds like a bad ignition switch, or even a bad ECM (computer) My foxbody did this when I first bought it, traced the problem to the computer and that fixed it, but it is rare that they go out. Try wiggling the key when the problems occur. And I have no idea why your fan kicked on unless the motor was that hot.
88 orangepeel notch is offline   Reply With Quote
Old 06-02-2014, 09:49 PM   #6
aode08
5th Gear Member
 
Join Date: Oct 2005
Location: Ohio USA
Posts: 4,616
Default

Quote:
Originally Posted by Aussie24 View Post
Today it started right up, Then it revered it self the went normal the went a bit more and stalled but then the radiator fan came on and I heard a clicking coming from where the relay for fuel and fan is. Could it just be the relay?

http://www.autozone.com/autozone/par...7020_880641_0_

The above part is overheating.
Usually the result of a bad fuel pump and fuel filter.
Parts needed at this point in year

All 5 parts.fuel pump, fuel pump filter, ccrm module,coil pack,and igntion control module/tfi module, needs replaced. Use a stock fuel pump, high drian units will fry the module again.
This is a very common issue with your year car.
aode08 is offline   Reply With Quote
Old 07-09-2014, 06:54 PM   #7
Aussie24
Thread Starter
 
Join Date: Oct 2012
Location: Lousiaina
Posts: 7
Default

I did a pressure test on the fuel pump it read 40psi with the key on and car was cold but then the radiator fan kicked on, Why I don't know but the psi went down to 30. I started the car and the psi was just over 40.Not sure if the fan came on and car stopped or not.
What could this be
Aussie24 is offline   Reply With Quote
Old 07-10-2014, 07:34 AM   #8
88 orangepeel notch
5th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 4,977
Default

I'm not familiar with the SNs, but I'd pull codes now to see what's up. Something is amiss in Mustang Land.
88 orangepeel notch is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sputtering low RPM when engine warms ShaneB26154 4.6L (1996-2004 Modular) Mustang 34 05-15-2016 09:30 AM
97 Convertible Power Top Wiring Diagram importsmasher V6 (1994-2004) Mustangs 4 10-09-2015 04:42 PM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 12:59 PM
Just swapped motor exhaust want fit daytooday Motor Swap Section 2 08-11-2015 09:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 02:53 AM.