Question after first throttle body cleanse - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 2005-2014 Mustangs
Reload this Page >

Question after first throttle body cleanse

Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Question after first throttle body cleanse

Reply

 
 
 
Old 05-13-2010, 08:06 AM
  #1  
shad2009
5th Gear Member
Thread Starter
 
shad2009's Avatar
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 2,244
Default Question after first throttle body cleanse

well...i took off the throttle body and cleaned it perfectly, then i re-installed it and went for a drive...she was roarin' louder, and there wasn't any lag like before...then, the next day, i'm driving and when i press on the brake, the car jerks, and when i release the brake it moves forward like i pressed on the gas(kinda like how a manual transmission moves when you go to shift from a stop)...today is only the second day after tyhe cleaning so i'll see if this continues, but has this happened to anybody else???
shad2009 is offline  
Reply With Quote
Old 05-13-2010, 08:30 AM
  #2  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Did you happen to disconnect the battery when you did it? Regardless, it's possible the PCM's adaptive learning is adjusting to the input changes. If you had an intake leak you'd have thrown a code.
Nuke is offline  
Reply With Quote
Old 05-13-2010, 09:32 AM
  #3  
shad2009
5th Gear Member
Thread Starter
 
shad2009's Avatar
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 2,244
Default

damn!!! i knew i forgot something
shad2009 is offline  
Reply With Quote
Old 05-13-2010, 12:08 PM
  #4  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Originally Posted by shad2009 View Post
damn!!! i knew i forgot something
Personally, I don't think you need to disconnect. But it's possible that the change from the cleaning had an impact on some input(s) to the PCM. I don't know why else the engine idle speed would be varying to cause the symptoms you described.

I'd give it about 25-50 miles of varied driving to see if it settles down.
Nuke is offline  
Reply With Quote
Old 05-13-2010, 12:24 PM
  #5  
shad2009
5th Gear Member
Thread Starter
 
shad2009's Avatar
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 2,244
Default

Thanx
shad2009 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Luke9222
4.6L General Discussion
19
10-23-2015 12:55 AM
94stangnewbe
V6 General Discussion
0
09-07-2015 08:39 PM
Webster454
2005-2014 Mustangs
1
09-07-2015 05:59 AM
Mustangmalo
General Tech
2
09-06-2015 06:22 PM


Thread Tools
Search this Thread
Quick Reply: Question after first throttle body cleanse


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.