02 Sensor HELP!!! - MustangForums.com

Notices
4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

02 Sensor HELP!!!

Reply

 
 
 
Old 07-03-2008, 01:31 PM
  #1  
bb816331
I ♥ Acer
Thread Starter
 
Join Date: Jun 2008
Location:
Posts: 232
Default 02 Sensor HELP!!!

Well most everyone here knows that I just got my car back from getting the tranny fixed, even though I just bought it Monday. Anyways, when they brought it back the check engine light was on. I took it over to my mechanic who said the code read back Oxygen Sensor Bank 1. We hoped at first that maybe when they dropped the tranny they unplugged it and forgot to put it back in. They put it on a lift and saw that all the 02's were in right. So he swapped the one throwing the code with one that wasn't, and the same Bank 1 was throwing the code. Meaning that the 02 is fine it's something else. He told me it was running lean. I have scheduled Monday to take the car to the ford house for a diagnostic. Then I'll have to relay the info to the dealer. I told the dealer I bought it from if it's a slight fix, then he's going to pay for it and what not. I told him if it's a major issue, then I'm just returning the car. I already called my bank and told them to not send my payment through 'till I get this resolved. Anyone have the slightest clue as to what's happening? Maybe a cat needs to be replaced? Maybe something is clogged up?? PLEASE HELP ME!!! I have to wait 'till freaking Monday to get an answer. The car itself is running fine, as if nothing was wrong. Could this be electrical? Let me know guys!!!

bb816331 is offline  
Reply With Quote
Old 07-03-2008, 03:08 PM
  #2  
bb816331
I ♥ Acer
Thread Starter
 
Join Date: Jun 2008
Location:
Posts: 232
Default RE: 02 Sensor HELP!!!

Heeeeeeeeeeeeeelp!
bb816331 is offline  
Reply With Quote
Old 07-03-2008, 04:44 PM
  #3  
cliffyk
TECH SAVANT
 
cliffyk's Avatar
 
Join Date: Dec 2006
Location: Saint Augustine, FL
Posts: 10,933
Default RE: 02 Sensor HELP!!!

Help with what, there are 20 orso O2 sensor related DTCs...[/align][/align]What code was thrown?[/align]
cliffyk is offline  
Reply With Quote
Old 07-03-2008, 05:54 PM
  #4  
bb816331
I ♥ Acer
Thread Starter
 
Join Date: Jun 2008
Location:
Posts: 232
Default RE: 02 Sensor HELP!!!

...Well I'm really not sure...However now that they pulled 'em out and put them back in I had the code reset and it hasn't turned back on yet...idk we'll see...
bb816331 is offline  
Reply With Quote
Old 07-03-2008, 10:08 PM
  #5  
bb816331
I ♥ Acer
Thread Starter
 
Join Date: Jun 2008
Location:
Posts: 232
Default RE: 02 Sensor HELP!!!

Ok so far so good, the code still hasn't tripped. Should I think everything is ok and as long as it doesn't turn back on, don't worry about it? Or should I still be concerned? Worst case I guess I should take it to be inspected before I do anything else, just to make sure there is nothing major wrong, correct?
bb816331 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jwog666
Pipes, Boost & Juice
6
01-07-2018 08:16 AM
Dathan
V6 (1994-2004) Mustangs
4
10-05-2015 06:52 AM
mrtrodonet
V6 (1994-2004) Mustangs
1
09-29-2015 12:13 PM
Big Al's 03
Mach 1 Section
4
09-21-2015 08:59 AM
TfcCDR
V6 (1994-2004) Mustangs
1
09-14-2015 01:08 PM


Thread Tools
Search this Thread
Quick Reply: 02 Sensor HELP!!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.