08 mustang gt bogs at wot after warmed up. - MustangForums.com

Notices
4.6L V8 Technical Discussions Any questions about engine, transmission, or gearing can be asked here!

08 mustang gt bogs at wot after warmed up.

Old 07-18-2018, 04:48 PM
  #1  
Nick Camarata
Thread Starter
 
Join Date: Jul 2018
Location: New York
Posts: 4
Default 08 mustang gt bogs at wot after warmed up.

hi im new to the forum, i have a 08 mustang gt that runs fine until it gets up to temp. it doesnt throw any codes. when it gets up to temp it runs ok at part throttle but if you give it more than 1/4 throttle or wot it bogs like crazy. not really sure what to do ive heard it could be coil packs?
Nick Camarata is offline  
Old 07-18-2018, 05:08 PM
  #2  
99GTvert
is my username.
 
99GTvert's Avatar
 
Join Date: May 2006
Location: Earth
Posts: 13,703
Default

How many miles are on the car and was any maintenance done to it recently?

Could be ignition related (spark plugs, coil packs), or gas related (bad gas or something) but I'm guessing the spark plugs.
99GTvert is online now  
Old 07-18-2018, 05:26 PM
  #3  
Nick Camarata
Thread Starter
 
Join Date: Jul 2018
Location: New York
Posts: 4
Default

it was my dads car it has been sitting for 8 months so im not sure about maintenance but i put fresh gas in it. has 131k on the clock,
Nick Camarata is offline  
Old 07-18-2018, 07:18 PM
  #4  
dusman59
1st Gear Member
 
dusman59's Avatar
 
Join Date: Jun 2011
Location: Arizona
Posts: 58
Default

Check fuel pressure.
dusman59 is offline  
Old 07-18-2018, 08:17 PM
  #5  
Nick Camarata
Thread Starter
 
Join Date: Jul 2018
Location: New York
Posts: 4
Default

i dont have a fuel pressure gauge, the car will rev all the way up just not if you give it full throttle its fine if you ease into it
Nick Camarata is offline  
Old 07-19-2018, 12:08 AM
  #6  
bl817
2nd Gear Member
 
bl817's Avatar
 
Join Date: Apr 2010
Location: Ft. Worth Tx
Posts: 440
Default

fuel filter.
bl817 is offline  
Old 07-19-2018, 12:27 AM
  #7  
Nick Camarata
Thread Starter
 
Join Date: Jul 2018
Location: New York
Posts: 4
Default

just curious, if it was fuel related why would it only do it when fully up to temp
Nick Camarata is offline  
Old 07-23-2018, 02:23 AM
  #8  
Dino Dino Bambino
3rd Gear Member
 
Dino Dino Bambino's Avatar
 
Join Date: Oct 2014
Location: Cyprus (EU)
Posts: 748
Default

Originally Posted by bl817 View Post
fuel filter.
My thought exactly.
Bogging is usually caused by a fuel delivery problem rather than an ignition misfire (unless it's on multiple cylinders). Since the car sat for so long either the gas has gone off, the fuel filter is clogged, or both.
Syphon off the old gas, refill with fresh gas, replace the fuel filter, and you should be good to go.
Dino Dino Bambino is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
95Saleen
5.0L (1979-1995) Mustang
7
09-10-2008 08:05 AM
Stang9946
General Tech
3
05-01-2008 11:18 PM
JChase
Classic Mustangs (Tech)
7
11-22-2007 03:37 AM
19stang86
5.0L (1979-1995) Mustang
4
11-10-2007 04:00 PM
69suns
5.0L (1979-1995) Mustang
3
09-01-2006 07:21 PM


Thread Tools
Search this Thread
Quick Reply: 08 mustang gt bogs at wot after warmed up.


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.