Pinging problem. - Page 2 - MustangForums.com

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Pinging problem.

Reply

 
 
 
Old 09-26-2004, 05:58 PM
  #11  
roundman
5th Gear Member
 
Join Date: Mar 2004
Location:
Posts: 4,813
Default RE: Pinging problem.

have you checked the voltage output signal from the TPS?? with the throttle normally closed, you want it to be .98-.99 volts. and I did tell you already to go with a bigger plug gap.
roundman is offline  
Reply With Quote
Old 09-26-2004, 06:03 PM
  #12  
Sykopny
Thread Starter
 
Join Date: Aug 2004
Location:
Posts: 11
Default RE: Pinging problem.

The TPS is set at .95 right now, so I am going to go outside and set it to .98,.99 and regap the plugs to .052. I'll post tomorrow after I get a good test drive to work and back. Keeping my fingers crossed. Thanks Roundman.
Sykopny is offline  
Reply With Quote
Old 10-23-2004, 12:10 AM
  #13  
Sykopny
Thread Starter
 
Join Date: Aug 2004
Location:
Posts: 11
Default RE: Pinging problem.

Sorry it took me a month to respond, but I finally had the problem solved. I took it and had it dyno tuned and found out my car was leaning out under load at high rpm. He (Steve at Powertrain Dynamics in Huntington Beach, CA) had to program and install a new chip. Baseline Rear wheel HP was 318 & torque 352, after the ninth pull and final burn of the chip, he got 332 HP & 366 torque. Feels good and pulls hard. He said that the TFS heads, TF Intake, F303 cam and 76mm MAF should be upgraded to AFR 205 heads, Holley Systemax Intake, Comp Cams High Energy Cam w/5.43 or higher lift & a 80mm 1999 Lighting MAF would get me into the 390 HP range. Do you agree? Yhanks for all the help. Hope this helps anyone who reads it.
Sykopny is offline  
Reply With Quote
Old 10-23-2004, 01:58 AM
  #14  
90Mustangfan
I ♥ Acer
 
Join Date: Jan 2004
Location:
Posts: 1,259
Default RE: Pinging problem.

sounds like you have a awsome setup, what do you run in the 1/4 mile...11's low low 12's, I bet you have problems hooking with that much hp
90Mustangfan is offline  
Reply With Quote
Old 10-23-2004, 01:48 PM
  #15  
roundman
5th Gear Member
 
Join Date: Mar 2004
Location:
Posts: 4,813
Default RE: Pinging problem.

ORIGINAL: Sykopny

Sorry it took me a month to respond, but I finally had the problem solved. I took it and had it dyno tuned and found out my car was leaning out under load at high rpm. He (Steve at Powertrain Dynamics in Huntington Beach, CA) had to program and install a new chip. Baseline Rear wheel HP was 318 & torque 352, after the ninth pull and final burn of the chip, he got 332 HP & 366 torque. Feels good and pulls hard. He said that the TFS heads, TF Intake, F303 cam and 76mm MAF should be upgraded to AFR 205 heads, Holley Systemax Intake, Comp Cams High Energy Cam w/5.43 or higher lift & a 80mm 1999 Lighting MAF would get me into the 390 HP range. Do you agree? Yhanks for all the help. Hope this helps anyone who reads it.
so what did he finally land up setting the timing at???
also it sounds like he wants to sell you a lot of new parts! LOL
I would be quite happy with the HP and torque numbers you are getting myself!
and you have to be careful on how much cam lift you go with and the valve sizes or you can run into a problem with piston to valve clearances too.
roundman is offline  
Reply With Quote
Old 10-23-2004, 10:26 PM
  #16  
vfast
I ♥ Acer
 
Join Date: Jul 2003
Location:
Posts: 11,394
Default RE: Pinging problem.

the problem is you selected the wrong cam to start with..you need one with more lift on the exhaust to take full advantage of those heads ..try using some 1.7 rocker on the exhaust side..
vfast is offline  
Reply With Quote
Old 11-07-2004, 07:24 PM
  #17  
Sykopny
Thread Starter
 
Join Date: Aug 2004
Location:
Posts: 11
Default RE: Pinging problem.

The tuner set the timing at 12 degrees. He said that with my Probe pistons that ar flycut for my TFS heads, that I could have a cam as large as .700 lift. I was thinking of changing it with a TFS stage 2 with a .542"/.563". I'll have plenty of clearance and the lift should be better. What intake would you suggest. I was thinking of the new BBK SSI set-up. Thanks Roundman.
Sykopny is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
69Volunteer
Classic Mustang General Discussion
1
09-30-2015 11:39 AM
bconboy
2005-2014 Mustangs
6
09-24-2015 02:55 PM
mdj89
5.0L (1979-1995) Mustang
7
09-23-2015 09:49 AM
ccdguy
5.0L (1979-1995) Mustang
1
09-19-2015 06:20 PM
cardsrus1
4.6L (1996-2004 Modular) Mustang
19
09-15-2015 09:37 AM


Thread Tools
Search this Thread
Quick Reply: Pinging problem.


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.