Suspension help needed - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-28-2009, 10:11 PM   #1  
chr1s5.0
Thread Starter
 
Join Date: Aug 2008
Posts: 8
Default Suspension help needed

So i spent all last summer slowly working on my engine as money came in, so i had the car up on stands most of the summer. Once i put it down i notcied the front of the car was sitting way too high, i thought it would settle down but still hasnt, the handleing is terrible now and it feels like im driving a cadilac like the front suspension is just floating. Im wondering what went wrong here if its bad struts or what.
chr1s5.0 is offline   Reply With Quote
Old 05-28-2009, 10:19 PM   #2  
AdderMk2
Banned
 
Join Date: Dec 2005
Location: Lil' Rhody
Posts: 22,376
Default

you could very well have damaged the struts leaving it up so long.. bounce the fender. if it has too much bounce to it.. then you need new shocks
AdderMk2 is offline   Reply With Quote
Old 05-29-2009, 03:41 PM   #3  
92tealcp
1st Gear Member
 
92tealcp's Avatar
 
Join Date: Feb 2009
Location: Exton Pa.
Posts: 76
Default struts

You have a strut problem.
92tealcp is offline   Reply With Quote
Old 05-29-2009, 04:53 PM   #4  
Portmaster
5th Gear Member
 
Portmaster's Avatar
 
Join Date: Nov 2008
Location: SC
Posts: 2,401
Default

Drive it down a washboard road. You have a Valve stuck in the strut. The washboard road may free it up
Portmaster is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Did a few mods this summer... drfister 2005-2014 Mustangs 11 05-03-2018 10:38 PM
total control triangulated 4 link rear suspension alymac New Member Area 2 08-26-2015 07:46 AM
Suspension Questions Mobiusone stang 2005-2014 Mustangs 6 08-24-2015 04:08 PM
Transferring suspension kits to newer Mustangs robjh22 S197 Handling Section 9 08-17-2015 07:35 AM
cruise issues defarmer 5.0L (1979-1995) Mustang 3 08-13-2015 06:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.