94 gt bucking / jerking on decel - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

94 gt bucking / jerking on decel

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

94 gt bucking / jerking on decel

Reply

 
 
 
Old 08-06-2015, 09:52 PM
  #1  
dfw692
Thread Starter
 
Join Date: Aug 2015
Location: nj
Posts: 3
Default 94 gt bucking / jerking on decel

Hey everyone, im hoping someone out there can help me out. I have been building my 94 gt for about a year now and have one hurtle I have not been able to get over. The car jerks and bucks on decal or light cruising to the point where I know something is going to break if I continue to drive it. It has edelbrock intake, 90mm lighting mass air,42lb injectors, lunati cam, bama tune, 3.73 gears, automatic trans with performance auto torque converter. It used to stall every time I put it in gear until I change the torque converter (fixed that). But still jerks and bucks, any thoughts or ideas would be extremely helpful. Im hoping to actually drive the car before winter. thanks all
dfw692 is offline  
Reply With Quote
Old 08-07-2015, 07:20 AM
  #2  
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Welcome to the forum.

Are the mods you listed the only mods on your car ? Just curious as to why you'd go so big on the MAF and injectors. Not saying it won't work in some cases, but it's way overkill on a slightly modded 302.

For your bucking/jerking, I'd start by looking for any vacuum leak. Smoke check it if you can. Google will show you how to make your own at home on the cheap, and its really the most accurate way to check for leaks.
88 orangepeel notch is offline  
Reply With Quote
Old 08-07-2015, 09:08 AM
  #3  
dfw692
Thread Starter
 
Join Date: Aug 2015
Location: nj
Posts: 3
Default

The only other upgrades are svo heads, headers, xpipe. I leak tested already and found nothing. It idles and accelerates great, but as soon you let off it bucks like a mule.
dfw692 is offline  
Reply With Quote
Old 08-07-2015, 04:18 PM
  #4  
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Funny that you posted this night. I was having a slight idle issue on mine, so I did a base idle reset. Now I have a nice idle again, but now she bucks a little in town in the lower gears at a steady speed. Not as bad as yours, but it wasn't there before I adjusted the idle. So that's where I'm going to start looking when I get home. Seems like the throttle body is allowing a surge of air thru, or something like that. I don't know, but I'll post back if I find anything.
88 orangepeel notch is offline  
Reply With Quote
Old 08-07-2015, 11:53 PM
  #5  
dfw692
Thread Starter
 
Join Date: Aug 2015
Location: nj
Posts: 3
Default

I'm wondering if its something in the transmission. Like something is not releasing when you let off the gas. Kind of feels like if you leave a manual trans in gear and slow down without downshift or putting into neutral. Very similar bucking feel.
dfw692 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mungodrums
5.0L GT S550 Tech
7
10-07-2015 04:01 AM
Matt's 95 Stang
5.0L (1979-1995) Mustang
2
10-05-2015 07:16 AM
jstrothe
V6 (1994-2004) Mustangs
2
09-24-2015 12:17 PM
SteelerNation82
V6 (1994-2004) Mustangs
1
09-16-2015 07:11 AM
zanemoseley
2005-2014 Mustangs
6
09-06-2015 12:58 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory