1993 5.0 won't rev above 1500 rpms and dies - MustangForums.com



5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 03-08-2017, 09:55 AM   #1
Miff01
Thread Starter
 
Join Date: Mar 2017
Location: TX
Posts: 1
Question 1993 5.0 won't rev above 1500 rpms and dies

Occasionally when I start the car, it will start, but won't rev above 1500 rpms. At 1500 rpms it starts bogging down and dies on me. This all happens within seconds of starting the car. I can instantly restart it and everything appears to be normal. This happens about once a week.

On a separate issue (but maybe related), I can be driving down the road at 55 to 65 mph, then out of nowhere the car instantly dies. I slam it in neutral, restart it and keep going. This also happens about once a week.

I think these issues might be related.

Do any of you guys have thoughts as to what might be causing this?
Miff01 is offline   Reply With Quote
Old 03-08-2017, 11:34 AM   #2
dawson1112
5th Gear Member
 
Join Date: Jul 2012
Location: ohio
Posts: 3,334
Default

Get a fuel pressure gauge you can monitor and watch your fuel pressure when it bogs down, could simply be a plugged fuel filter . Thats where I would start.
dawson1112 is offline   Reply With Quote
Old 03-13-2017, 07:43 AM   #3
88 orangepeel notch
5th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 4,890
Default

Going off your discription, fuel related issue gets my vote too.

Post back with what you find or any other updates.
88 orangepeel notch is offline   Reply With Quote
Old 03-13-2017, 04:21 PM   #4
yurizx6r
3rd Gear Member
 
yurizx6r's Avatar
 
Join Date: Sep 2011
Location: Florida
Posts: 609
Default

I had a similar issue to where my fox wouldn't start easily. It seemed fine once you got it started, but anything after 3,000 RPMS it would backfire. After checking the fuel pressure, battery, vacuum leaks, TFI, MSD box, and such it turned out to be the ignition coil (MSD and it was only two years old).
yurizx6r is offline   Reply With Quote
 
 
Reply


Tags
dies on start, won't rev

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:42 PM.