Need Clutch Adj. Help! At My Wits End - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-21-2006, 12:19 AM   #1  
fastfox86
2nd Gear Member
Thread Starter
 
Join Date: Mar 2005
Posts: 316
Default Need Clutch Adj. Help! At My Wits End

Here's the shorto of it.

Did a T-5 swap, started the car, rattling from the bellhousing, I'm thinking, maybe the bearing or fork I used just suck, but people on the forums say add tension to the cable and it will quit. I added tension and made it quit, but by the time it quit there was no freeplay on the pedal so the clutch would be constantly engaging and burn up. So I ordered a fork from Ford dropped trans and replaced fork and bearing just to be safe, verified they were installed correctly, bolted everything back up, adjusted the cable and it's still making the noise. Now I'm thinking maybe my cable and quarant are crap. They are UPR knock offs I got on ebay.

I currently have: Adjustable cable
3 hook quadrant with the cable hooked on 2
Firewall Adjuster

CAN ANYONE PLEASE HELP ME? I'M GOING INSANE AND I JUST WANT TO DRIVE MY BABY AGAIN!
fastfox86 is offline   Reply With Quote
Old 02-21-2006, 09:12 AM   #2  
stanglx2002
6th Gear Member
 
Join Date: Feb 2005
Location:
Posts: 5,205
Default RE: Need Clutch Adj. Help! At My Wits End

click on my tech articles and go to quadrant......install
stanglx2002 is offline   Reply With Quote
Old 02-21-2006, 03:46 PM   #3  
fastfox86
2nd Gear Member
Thread Starter
 
Join Date: Mar 2005
Posts: 316
Default RE: Need Clutch Adj. Help! At My Wits End

I've read that whole page and nothing on there helps me with the problem. If I adjust to where it feels right and engages and releases at the proper points, it makes the horrible rattling sound. If I put enough tension on the cable to make it stop, The clutch doesn't engage until the pedal is all the way up and there is no freeplay in the pedal at all. Now if I'm sitting in the car and I put the tiniest bit of pressure on the pedal with my foot it will stop, but if I adjust the cable so it stops, the clutch engages way to high and I'm afraid of burning it up.
fastfox86 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Chirp during hard shifts? 6bangr 4.6L V8 Technical Discussions 5 02-15-2016 07:40 AM
2005 Mustang - Transmission rattle and slippage/stuttering AmericanMuscle4.6GT 2005-2014 Mustangs 7 11-10-2015 02:06 PM
1995 Mustang GT RAM HDX / TOB noise problem after install? ccdguy 5.0L (1979-1995) Mustang 1 09-19-2015 05:20 PM
Time for a new clutch? MasterLanMan 4.6L (1996-2004 Modular) Mustang 6 09-13-2015 08:21 PM
Huge Savings from Lethal Performance.com!(Whipple, McLeod, Kooks, & MUCH MORE..) Boostaddict Lethal Performance 2 09-08-2015 09:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 09:58 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.