fix wheel hop - MustangForums.com


5.0L General Discussion This section is for non-tech specific information pertaining to 5.0L Mustangs.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-29-2008, 11:07 PM   #1  
87slutstang
1st Gear Member
Thread Starter
 
87slutstang's Avatar
 
Join Date: Nov 2008
Location: california
Posts: 136
Default fix wheel hop

just installed new control arms and springs, now it has wheel hop really bad. how do i fix it.
87slutstang is offline   Reply With Quote
Old 11-29-2008, 11:13 PM   #2  
ctgreddy
6th Gear Member
 
Join Date: May 2007
Location: Dearborn, MI
Posts: 6,277
Default

are the ca's adjustable? if so your pinion angle's prolly messed up and you need to adjust the ca's
ctgreddy is offline   Reply With Quote
Old 11-29-2008, 11:23 PM   #3  
kweb288
5th Gear Member
 
kweb288's Avatar
 
Join Date: Feb 2007
Location: St. Charles Il, and ISU
Posts: 3,736
Default

ya the same thing happened when i changed mine lol, another thing to look at is your upper control arm bushings on the pumkin.
kweb288 is offline   Reply With Quote
Old 11-29-2008, 11:42 PM   #4  
87slutstang
1st Gear Member
Thread Starter
 
87slutstang's Avatar
 
Join Date: Nov 2008
Location: california
Posts: 136
Default re

no they are not. should i put the quad shocks on?
87slutstang is offline   Reply With Quote
Old 11-30-2008, 09:13 AM   #5  
projectresto83
M.A.D. Motorsports
 
projectresto83's Avatar
 
Join Date: Jul 2006
Location: Indiana
Posts: 8,011
Default

Cheaper arms will cause wheel hop from what I have seen. Are they the summit ones in your sig? If so I almost guarantee that is why you have wheel hop. That is one place that I am not gona skimp on when it comes to replacing mine.
projectresto83 is offline   Reply With Quote
Old 11-30-2008, 10:32 AM   #6  
USMC1775
4th Gear Member
 
USMC1775's Avatar
 
Join Date: Aug 2006
Location: The P.R.K.
Posts: 1,975
Default

Try replacing the quads, or if you didnt during the swap, like said before, replace the upper bushings on top of the diff
USMC1775 is offline   Reply With Quote
Old 11-30-2008, 12:37 PM   #7  
87slutstang
1st Gear Member
Thread Starter
 
87slutstang's Avatar
 
Join Date: Nov 2008
Location: california
Posts: 136
Default re

thanks, the quads aren't on right now. i'll put them on and see what happens. i have some bushings on the way. i'll keep you posted.
87slutstang is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wheel Question! (New member, hi folks) Tivo304 New Member Area 5 05-30-2018 04:58 PM
11" wide rear wheels/tires mmarsh3014 Wheels & Tires 1 10-20-2015 09:08 AM
Blew my rear end :( 67LimeCoupe 5.0L (1979-1995) Mustang 31 09-30-2015 04:46 PM
2005 GT Intermittent Low Rail Pressure Throttle Drop zanemoseley 2005-2014 Mustangs 6 09-06-2015 12:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:13 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.