TPS sensor wont stay in? HELP! - MustangForums.com

Notices
GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

TPS sensor wont stay in? HELP!

Reply

 
 
 
Old 09-18-2009, 02:30 PM
  #1  
lundis
1st Gear Member
Thread Starter
 
Join Date: May 2007
Location: long island, NY
Posts: 111
Default TPS sensor wont stay in? HELP!

hey guys/gals,

i installed a set of CMCV deletes, and now my TPS sensor wont stay in. the red latch clicks in, but the harness pops off the sensor VERY EASILY. i have it taped on right now, which is pretty ghetto, but i dont know how to fix this permanently. any ideas?
lundis is offline  
Reply With Quote
Old 09-18-2009, 03:03 PM
  #2  
shanec
4th Gear Member
 
shanec's Avatar
 
Join Date: Aug 2008
Location: Mississippi
Posts: 1,679
Default

To separate that connector, you should have to push a lever down. If the connector comes apart without pushing anything down, the connector is broken. You should be able to look at it and see where the plastic is supposed to latch. I bet something has broken off.

If that's it, you should be able to buy a new connector and move the pins over to the new connector and be good to go.

Moving the pins over isn't hard. Its a little tedious. I can give you tips on that if you have to go there. Number one rule of advice on that is not to force anything. There's a method to do it and if the pins don't come out easily you're not doing it right.
shanec is offline  
Reply With Quote
Old 09-18-2009, 03:22 PM
  #3  
lundis
1st Gear Member
Thread Starter
 
Join Date: May 2007
Location: long island, NY
Posts: 111
Default

i was thinking of calling up some junkyards to see if anyone has it, and just cut off the connector, splice it in my car...

something on the connector is definitley broken. any chance ford will sell it with bare wires coming out? or can i buy it from somewhere?
lundis is offline  
Reply With Quote
Old 09-18-2009, 05:03 PM
  #4  
157dB
Cut & Paste Expert
 
157dB's Avatar
 
Join Date: May 2007
Location: NW Arkansas
Posts: 13,322
Default

Originally Posted by lundis View Post
i was thinking of calling up some junkyards to see if anyone has it, and just cut off the connector, splice it in my car...

something on the connector is definitley broken. any chance ford will sell it with bare wires coming out? or can i buy it from somewhere?

Whoa there Coyboy.
Think bout the next owner before cuttin and splicing....
157dB is offline  
Reply With Quote
Old 09-18-2009, 05:05 PM
  #5  
shanec
4th Gear Member
 
shanec's Avatar
 
Join Date: Aug 2008
Location: Mississippi
Posts: 1,679
Default

I know a guy who bought a factory connector similar to that one and it came with no wires in it.

I have a picture I'll post later that shows how to re-pin a connector. I got plenty of practice with this when I installed my supercharger, LOL. You need a really small pic like tool. I found one in a cheap screwdriver & pick set at Advance Autoparts. It came with 4 small screwdrivers and 4 tools that look like dental instruments - pics bent at different angles.

You need to 1) pry up the wedge lock which is the colored piece of plastic pushed over the ends of the pins inside the connector, 2) push a small pic in there and gently pry at just the right spot, and 3) gently pull the wire out with its pin still connected to the wire.

Again, i've got pics on this and I'll try to remember to post them. Unfortunately, photobucket is blocked here at work.
shanec is offline  
Reply With Quote
Old 09-18-2009, 06:30 PM
  #6  
shanec
4th Gear Member
 
shanec's Avatar
 
Join Date: Aug 2008
Location: Mississippi
Posts: 1,679
Default

I'm not sure what connector this is in the picture, but they all work about the same. That surrounding red plastic is called a wedge lock. It can be pryed up and removed from the connector.




This is a connector after its had the pins removed.



Now look closely at the inner edge along the bottom. See those little vertical nubs? Now look just above those at the horizontal tabs that are brightly lit by the glare of the sunshine. I'm referring the 1st horizontal shape you see just above the top of those vertical nubs.

Those are the tabs you have to deal with in getting the pins out. Those tabs push up on the bottom side of the pins.

You have to insert a pic between the pin and that tab. You pretty much do this blind because you won't be able to see in there. In the pic above, you would need to push the tab down so the pin will back out of the connector.

You will not be able to feel the connector. Just stick the pic in and push down while you try pulling out the wire. Don't force anything. And you might need a 3rd hand to help.

If you can't find the tab, just stick the pic in and wiggle it around while somebody is gently pulling the wire and you'll probably trip the tab. I did my first couple like that and by the 3rd or 4th, I was able to do all this pretty quick & easy.
shanec is offline  
Reply With Quote
Old 09-18-2009, 06:31 PM
  #7  
shanec
4th Gear Member
 
shanec's Avatar
 
Join Date: Aug 2008
Location: Mississippi
Posts: 1,679
Default

delete double post
shanec is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jwog666
Pipes, Boost & Juice
6
01-07-2018 08:16 AM
Dathan
V6 (1994-2004) Mustangs
4
10-05-2015 06:52 AM
folivier
Tennessee Regional Chapter
4
10-02-2015 06:32 AM
mrtrodonet
V6 (1994-2004) Mustangs
1
09-29-2015 12:13 PM
TfcCDR
V6 (1994-2004) Mustangs
1
09-14-2015 01:08 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory