Suspension Popping - 06 GT - MustangForums.com



GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-17-2014, 11:49 PM   #1  
veloccity
Thread Starter
 
Join Date: Apr 2014
Location: WA
Posts: 12
Default Suspension Popping - 06 GT

Hey guys, my 06 has always made a popping sound going over small bumps sounds like its mostly from the front. Cant feel it in the wheel but sounds like tie-rods to me but I am not sure on this car. Could it be the strut mount? I heard those can fail. Wondering if this is a common issue.

More strangely I notice a similar popping or bumping sound but coming from the front and rear while turning right to park into a parking lot. This only occasionally occurs and I only ever hear it while turning right.

Just looking for thoughts.

Thanks.
veloccity is offline   Reply With Quote
Old 09-18-2014, 07:41 PM   #2  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

There's a TSB for a front end clunk. But before you go to the dealership, have you checked the strut hardware tightness?
Nuke is offline   Reply With Quote
Old 09-19-2014, 01:38 PM   #3  
veloccity
Thread Starter
 
Join Date: Apr 2014
Location: WA
Posts: 12
Default

I haven't yet, no. I will get it up this weekend and check the bolts.

What would cause the popping in the back? Similar sound but definitely from the back of the car. Swaybars?

I haven't worried about it to much, but we've had a lot of construction on the road near our house and the constant driving over rough road has really exacerbated the issue.
veloccity is offline   Reply With Quote
Old 09-19-2014, 09:46 PM   #4  
UPRSharad
Sponsor
 
UPRSharad's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 2,568
Default

Also check the swaybar end links in the front. They're notorious for making noise.
UPRSharad is offline   Reply With Quote
Old 09-23-2014, 11:56 AM   #5  
Simon1
5th Gear Member
 
Join Date: Dec 2006
Location: Redding, CA
Posts: 4,566
Default

Quote:
Originally Posted by UPRSharad View Post
Also check the swaybar end links in the front. They're notorious for making noise.
Yes! This my problem. You need to wrenches to get them tight, one 8 mm on the end and an 18mm on the other. Problem solved, for me at least.
Simon1 is offline   Reply With Quote
Old 09-23-2014, 10:31 PM   #6  
UPRSharad
Sponsor
 
UPRSharad's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 2,568
Default

Quote:
Originally Posted by Simon1 View Post
Yes! This my problem. You need to wrenches to get them tight, one 8 mm on the end and an 18mm on the other. Problem solved, for me at least.
Excellent!
UPRSharad is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starting a new project....could use some input. Matt's 95 Stang 5.0L (1979-1995) Mustang 2 10-05-2015 07:16 AM
2002 convertible driver window issue cr620 V6 (1994-2004) Mustangs 1 10-03-2015 06:39 AM
GT500 front LCA question UrS4 S197 Handling Section 1 09-30-2015 10:13 AM
Car Suspension problems? marc954 4.6L (1996-2004 Modular) Mustang 2 09-29-2015 11:18 AM
91 vert tailpipe smoking MacSerio 5.0L (1979-1995) Mustang 3 09-27-2015 01:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.